Versions PHP selon le CMS

lordbdp

New Member
#1
Bonjour,

J'ai tenté d'installer :
Webcal -> Il me dit impossible car j'utilise php 5.5.38 et il veut 5.6.0+
phpical-> Il me dit impossible car j'utilise php 7.0.27 et il veut en dessous du 7.0.0

Comment je fais ???
 

PH-Gabriel

Moderateur
Membre du personnel
#5
En effet, le World Lite ne permet pas ceci. Par contre, l'offre payante de World va vous le permettre.

Je viens de vérifier et World Lite utilise la version de PHP 7.0.27.
 

PH-Gabriel

Moderateur
Membre du personnel
#7

lordbdp

New Member
#8
Mais c'est pour vous les infos pour les patchs et modifications à faire. C'est sur vos serveurs ^^
 

PH-Gabriel

Moderateur
Membre du personnel
#9
Ces modifications sont à faire au niveau de votre CMS. Le serveur fonctionne bien avec le version 7 de PHP.

Si vous ouvrez le fichier que vous avez envoyé, vous allez pouvoir voir qu'il modifie des fichiers php du CMS.
 
#11
Tu replaces bien les lignes de code dans les différents fichiers indiqués dans le fichier diffs.txt ?
 

lordbdp

New Member
#12
le - en début de ligne veut dire que je dois supprimer cette ligne et + pour que je remplace par cette ligne ?

Exemple :

- $filesys = eregi_replace("/","\\", $filename); -> Je supprime cette ligne
+ $filesys = preg_match("/\//","\\", $filename); -> Je rajoute cette ligne
 

lordbdp

New Member
#13
modifications faites ;)

Maintenant je me prends la tête à paramétrer config.inc.php et default_config.php
 

lordbdp

New Member
#14
Pour
'calendar_path' => '/Library/WebServer/Documents/phpicalendar/calendars/recur_tests',
quoi que je mette il me dit que le lien n'est pas bon, j'ai même tenté de mettre le lien en dur pour voir mais pas bon, j'ai testé aussi avec =>' ' résultat négatif
 
#15
Tu as essayé de mettre un truc du style :
"/home/compte_cpanel/public_html/dossier_calendrier" ?
 

lordbdp

New Member
#16

Fichiers joints

#17
Je ne connais pas ton CMS...
Le support de ce dernier devrait pouvoir t'aider... Ou le forum de la communauté si il y en a un.

Pour la page blanche tu dois avoir une erreur PHP mais par défaut leur affichage est désactivé.
Je ne sais pas si tu as accés au cPanel sur ton hébergement, si c'est le cas vas ici :
PHP Selector > Switch To PHP Options
A la ligne "display_errors" tu mets on
A la ligne "error_reporting" tu mets E_ALL


Sinon dans ton htaccess ajoute ceci au tout début :
Code:
# Displaying PHP errors
php_flag display_errors on
 
#21
Il n'y avait pas quoi?
Parce que sur ton screen je le vois "gestionnaire multiphp".... Qui est la traduction de ce que je te disais juste au dessus....

Pour l'erreur 500 ça peut être un peu tout et n'importe quoi...

Vérifie les modification que tu as faites dans les différents fichiers au cas où...

Et essaie de voir avec le support de ton CMS parce que là ça va devenir trés compliqué de t'aider
 
#23
Autant pour moi
Tu es en hébergement Lite, cette option ne doit pas être dispo pour toi...

Par contre pour ton soucis je te laisse regarder mon post précédent.... Je ne peux malheureusement pas faire mieux :(
 

PH-Gabriel

Moderateur
Membre du personnel
#25
Je viens de tester la méthode de modifier le .htaccess proposé par David sur votre World Lite et l'affichage d'erreur fonctionne bien. Pouvez-vous vérifier svp ?

Si votre site est sur le VPS, n'hésitez pas d'envoyer un ticket de support afin de vous assister.
 

lordbdp

New Member
#29
non donc je laisse de coté en attendant que la communauté trouve une solution ou sorte une version qui fonctionne...
 
Haut