Transfert de site sous Joomla et page blanche

Naw3r

New Member
#1
Bonjour,

Y a t-il des expèrts de Joomla ici ? ;)

J'ai souscris à une offre PH cette semaine, et j'ai donc dû transféré mon site :
j'ai copié tous mes fichiers sur mon nouvel hébergement, j'ai importé ma base de données via phpmyadmin et j'ai modifié le configuration.php pour mettre à jour les infos d'accès à la SQL....Sauf que j'ai une page blanche, je n'ai accès ni au site ni au backend (administration).

J'ai donc tenté autre chose.
J'ai donc supprimé ma base de donnée, fait une nouvelle installation de joomla propre : tout fonctionne. J'ai ensuite recopié mon site sur l'installation neuve (à l'exception du configuration.php) et importez ma base de données... mais même problème : page blanche.

Que faut-il faire ?
C'est assez embarrassant et je ne sais pas par où m'y prendre, par contre il est claire que ça vient de la base de données....

J'espère que quelqu'un saura m'aider. Mille merci!

Naw3r

ps: je précise qu'il n'y a pas d'index.html à la racine.
 
Dernière édition:

Naw3r

New Member
#3
Salut,

Effectivement mon dossier "cache" n'était pas vide.
Je viens de le vider et toujours pareil.

J'ai aussi tenter de désactiver mon .htaccess mais ça ne change rien..
 

Naw3r

New Member
#6
J'ai fait quelques tests en plus aujourd'hui :

mon site fonctionne parfaitement en local. Dés que je le met en ligne, page blanche.
C'est donc un problème de configuration avec planethoster, peut-être faut il un .htaccess spécial ?
 

Naw3r

New Member
#7
Il semblerait que le problème vienne de la version My SQL (4.1.22) qui est trop ancienne. Sur mon ancien hébergeur la version de Mysql était en 5.0.51 donc il faudrait au moins du 5.x.x .

(De plus en local j'ai du 5.1.46 et ça fonctionne nickel).

Je vais créer un ticket pour savoir comment changer la version :) .
 

atoohost

New Member
#8
Bonjour,

j'ai tous mes site en joomla sur planethoster sans aucun problème, par contre je ne fais que des install manuelle pas avec script fantastico.

Pour ton site et son transfert tous dépend des extension et effectivement le .htaccess est important pour un bon fonctionnement.
je te confirme qu'il n'y a pas d issue avec la version sql de PH.

Pour t 'aider il me faut plus d info sur tes module et notamment si tu fais de l url rewriting
 
Dernière édition:

Naw3r

New Member
#9
Salut,
Merci pour ta réponse.
Pareil je n'utilise pas Fantastico.

En fait j'ai trouvé une solution:

J'ai fait une nouvelle installation de joomla, et j'ai importé mes articles, users, sections... par phpmyadmin
Ensuite j'ai installé mes extensions une par une, et à chaque fois j'ai importé par dessus les tables via phpmyadmin de l'extension...
J'ai pû donc reconstruire mon site (ça m'a pris toute l'aprême), et là je viens de remettre mon .htaccess et j'ai ativé le SEF et tout marche!

Je ne comprends pas d'où ça vient mais l'important c'est que mon site est de nouveau en ligne.
 

atoohost

New Member
#10
Bien il existe un outil de sauvegarde pour joomla base de donnée et autre je l utilise pour faire les transfert sur pH quelque minute suiffise je te retrouverai le nom
le principe sauvegarde du local puis installation comme si c était joomla et sa roule
 

Naw3r

New Member
#11
Akeeba backup ?
Je m'en suis servi pour importé mon site sur PH = page blanche
J'ai réssayé en faisant tout manuellement = page blanche
La seule solution que j'ai trouvé est de partir d'une nouvel installation propre de joomla et de tout réinstaller...
 

atoohost

New Member
#12
Je crois que c'est le composant de sef qui peut bloquer, je ne l installe pas en local mais que online une fois le site transferer, mais oui akeeba fonctionne bien sinon.
 
Haut