Ticket : DMW-795-66460 / .htacess et rewriting

Discussion dans 'Hébergements Mutualisés' démarrée par vdc1, Aou 7, 2012.

  1. vdc1

    vdc1 New Member

    Bonjour,

    Je suis une nouvelle cliente.
    Le site est actif sur son adresse permanente.
    Hier en début de soirée j'ai émis un ticket DMW-795-66460, depuis aucune nouvelle, personne ne semble l'avoir pris.
    NB : j'ai déjà un autre hébergeur depuis 10 ans pour mes autres sites, je voulais alterner pour cette fois vu les éloges sur le service client...

    Mon souci est lié au rewriting.

    J'ai testé mon htaccess et mes fichiers chez mon autre hébergeur, cela fonctionne ainsi que sur mon serveur local, mais pas sur le serveur planethoster...
    Plus précisément, le rewrite fonctionne partiellement.
    Aucun souci, pour les adresses du style :
    ex : http://www.nomdedomaine.com/toto.html (= index.php?page=toto)
    par contre, pour les répertoires virtuels : souci
    ex : http://www.nomdedomaine.com/repertoire-virtuel/toto.html

    Cela me génère une erreur include
    => Failed opening 'repertoire-virtuel/toto.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php')

    Quelqu'un a-t-il l'info ? Cela doit être une petite subtilité que j'ai ratée... j'ai cherché dans le forum, mais pour l'instant rien de probant dans mon cas...

    Merci :)
     
  2. vincent

    vincent New Member

    Pour pouvoir t'aider met aussi le contenu de ton .HTA ici avec la balise
    Code:
    , histoire de voir les regles.
     
  3. vdc1

    vdc1 New Member

    Le code. Merci :)

    Merci pour ton aide :)

    NB : Je ne suis pas une ingé. Ce qui m'étonne est la réussite de l'inclusion chez mon autre hébergeur + sur mon serveur local, et son échec sur le serveur de Planethoster... Je me demande si cela vient d'une subtilité ratée ou d'une grossière erreur de ma part

     
    Dernière édition: Aou 7, 2012
  4. vincent

    vincent New Member

    c'est pour quelle cms ? ca me parait un peut leger comme regle la.

    essaye de mettre un RewriteBase /
     
    Dernière édition: Aou 7, 2012
  5. vdc1

    vdc1 New Member

    Bonjour Vincent et merci,

    J'ai contacté le service technique par tél. : l'hébergement est sur litespeed et non apache d'où un souci d'interprétation des variables envoyées lors de la réécriture. Il ne trouve pas la variable id... alors que son ami Apache oui... Logiquement cela devrait se résoudre en modifiant l'hébergement (en passant sur Apache).

    NB : ce n'est pas un CMS. Je n'ai indiqué que les règles de réécriture dont j'ai besoin dans le cadre de ce site.

    Merci pour ton aide :)
     
  6. vdc1

    vdc1 New Member

    Résolu

    C'était un truc bête : l'ordre des règles. J'ai inversé et cela fonctionne. La vie est simple parfois :)
     

Partager cette page