[Resolu] Mauvaise redirection d'une page une fois le site hébergé [FluxBB]

k0h

New Member
#1
Bonjour à tous !
Je m'adresse à vous car j'ai un petit problème.
Quand je suis connecté sur un compte admin ou n'importe le quel et que je souhaite cliquer sur le bouton "profil" pour accéder à mon profil, ça me redirige vers une page blanche, ça me dirige vers "profil.php" alors que ça devrait me rediriger vers "profil.php("utilisateur")" quand je test en local tout fonctionne normalement.
Alors, voici ce qu'il ce passe en local quand je souhaite accéder à mon profil d'utilisateur étant connecté :
http://prntscr.com/pfdn0o
Comme l'image le montre, ça me redirige bien vers ma page utilisateur.
Voici ce qu'il ce passe quand je souhaite accéder à cette même page sur mon site héberger chez PlanetHoster : http://prntscr.com/pfdndd
Pourtant, je suis connecté sur le même utilisateur qu'en local.
Quelqu'un m'a dit que ça devait venir de ça :
  • versions de PHP différentes
  • fonctions bloquées/indisponibles
  • configurations de PHP différentes (je pense notamment à l'output_buffering à off qui "bloque" les fonctions d'entête)
  • tu as des scripts plutôt lourds, peut être que leur exécution est écourtée parce que tu atteins le memory_limit et/ou le max_execution_time (il faut se dire que dans le cas d'un serveur gratuit, ces paramètres sont généralement plutôt restrictifs, ce que l'on peut comprendre)
  • etc
Voici mon utilisation du disque planethoster : http://prntscr.com/pfnp6j
Pensez-vous que cela vient du fait que c'est simplement lié à la configuration du serveur, sachant que j'ai des scripts lourds pour la version Lite ? ? Ce qui m'arrangerais beaucoup car je comptais prendre une version payante.
Si quelqu'un à besoin de code, je peux bien-sur fournir des pages sur pastbin.
 
Dernière édition:
#2
Pour les informations à propos de php, tu peux les obtenir avec la fonction phpinfo()
Crée un fichier php avec les codes suivants et exécute le en ligne :

<?php
phpinfo();

La plupart du temps, les erreurs viennent de nos codes. Déboguer un code écrit par une autre personne demande pas mal de temps sauf si tu a utilisé un framework comme Symfony ou Laravel. Est-ce le cas ?
 

k0h

New Member
#3
Salut, merci de ta réponse. C'est FluxBB 1.5 du coup la version!
Malheureusement je ne sais pas ce qu'est un Symfony/Laravel, ni même un framework.
Je dois en déduire que l'erreur vient de mon code ? Si c'est le cas j'aurai pas le choix malheureusement d'essayer de trouver quelqu'un capable de me corriger ça..
 
#4
Je viens de tester en installant FluxBB avec Softaculous sur WorldLite et je n'ai aucun problème. Je viens de te lancer une conversation.
 
Haut