Règle htaccess qui fonctionne mais pas du premier coup !

Discussion dans 'Hébergements Mutualisés' démarrée par Rathorian, Jan 21, 2014.

  1. Rathorian

    Rathorian New Member

    Bonsoir,

    Je me retrouve avec un souci sur mon hébergement mutualisé.

    J'ai un fichier à la racine de mon hébergement et je souhaite que personnes puissent y accéder.
    Le fichier en question possède aucune extension, il est donc simplement du type "blabla".

    Ma règle dans le htaccess à la racine de l'hébergement :
    Code:
    <Files "blabla">
    	Order allow,deny
    	Deny from all
    </Files> 
    Puis quand j'accède à mon site via mon nom de domaine :
    Code:
    http://www.nom-de-domaine.fr
    Tout est OK, heureusement... mais quand j'essaye ensuite d'aller voir si le fichier est bien bloqué :
    Code:
    http://www.nom-de-domaine.fr/blabla
    Le fichier apparait quand même la première fois.
    Puis si j'actualise je n'ai finalement plus accès au fichier mais seulement après avoir actualisé la page.

    Je comprend pas pourquoi j'ai ce problème.
    Sachant que j'ai vidé mon cache du navigateur etc etc...

    Auriez-vous une idée du problème auquel je suis confronté ?

    Merci
    Cordialement
     
    Dernière édition: Jan 21, 2014
  2. Rathorian

    Rathorian New Member

    Bonjour,

    Finalement aujourd'hui tout fonctionne correctement.
    Donc désolé du topic inutile.

    Cordialement
     
  3. hannuman

    hannuman Member

    C'est peut-être à cause de la mise en cache dans le navigateur : si tu as accédé au fichier une première fois, le .htaccess n'est pas pris immédiatement en compte puisqu'il n'existait pas la première fois.
    Par contre, ça devrait être bon pour un nouveau visiteur, ou un autre navigateur.
     

Partager cette page