Problèmes après installation d'un CMS

Discussion dans 'Hébergements Mutualisés' démarrée par Thanae, Fév 24, 2017.

  1. Thanae

    Thanae New Member

    Bonjour,

    Je ne suis pas tout à fait nouvelle chez PlanetHoster, mais si depuis la nouvelle plateforme World.
    J'ai installer via Softaculous CMS Made Simple, avant, il y a 3 ans j'avais sur l'ancienne plateforme Wordpress.
    Maintenant suite à ca j'ai deux questions:
    1/ quand j'ouvre PhpMyAdmin, j'ai que la DB "information_schema", je ne vois pas celle qui a été créé pour le CMS. Je constate que les DB créé automatiquement un nouveau user complémentaire au principal, hors PhpMyAdmin s'ouvre qu'avec le principal. Comment alors accéder a ma nouvelle DB avec mon user principal, ou sinon, comment me connecter avec le nouveau user.
    2/ une fois installation faite, j'ai pu ouvrir le site et le panneau Admin. Puis j'ai voulu un peu voir ce qui avait par défaut et j'ai été renvoyée à la doc du site de CMS Made Simple. Quand j'ai voulu réouvir mon site, plus rien. Message d'erreur "Site Not Found" "he requested website was not found on WorldHTTP.""If it is a new site, please try after a few mins."
    Bon cela fait maintenant des heures et toujours rien, j'ai vérifié et tout à l'aire correct.
    Pour info, j'ai un sous-domaine, j'avais déjà essayer d'installer le CMS mais apparement le sous-domaine était mal redirigé je recevait le message "Network Error (dns_unresolved_hostname)". J'ai alors tout supprimer et désinstaller, puis recreer le sous-domaine correctement et refait l'installation en vérifiant bien il s'installe dans le répertoire du sous-domaine. Donc tout était bien configuré puisque j'ai pu y accéder, ne fus que pour 5 min.

    Voilà, si quelque peut m'aider, j'ai pas envie de devoir a nouveau tout redefaire et refaire.

    Merci d'avance pour votre aide.
     
    Dernière édition par un modérateur: Nov 10, 2017
  2. David77

    David77 Member

    En effet c'est étrange car normalement ton compte principal cPanel doit pouvoir avoir accés à toutes les bases de données du compte.
    Le user créé ne sert à travailler avec cette base.

    Tu peux installer phpmyadmin sur ton FTP pour te connecter avec ce compte user spécifique mais cela n'est pas forcement simple, tout dépend de ton niveau

    Quand est-il sur ton FTP ?
    Vois-tu toujours tes fichiers ?
     
    Dernière édition par un modérateur: Nov 10, 2017
  3. Thanae

    Thanae New Member

    1/ en effect c'est ce que je me disais, dans le passé je voyais toutes mes db avec le user principal, d'où ma question. Pourtant j'ai installer et désinstaller plusieurs fois. J'ai même en créé manuellement une db via MySql Database. Et toujours pareil, je ne vois rien dans phpMyAdmin.

    2/ je vois bien tout mes fichiers, rien n'as changé. J'avais juste ouvert config.php pour voir les parametres, mais sans modifications. Donc tout est à l'identique que lorsque installation a terminé. C'est ca qui m'interpelle, ca a fonctionné quelques minutes, puis plus rien.
     
  4. David77

    David77 Member

    Je pense qu'il va falloir que tu te rapproches du support ne serait-ce que pour ton soucis de bases de données :(
     
  5. François D

    François D Member

    Concernant le problème avec phpMyAdmin, voir avec le support.

    Le problème pourrait se situer au niveau de l'utilisateur inscrit dans la configuration du phpMyAdmin. Ce qui m'est arrivé.

    Une façon de le voir est d'utiliser la console (en bas du phpMyAdmin) et exécuter :

    select user();
    et
    select current_user();

    La première me donnait
    MONUSER@world.ca.planethoster.net

    La deuxième me donnait
    MONUSER@IPDUSERVEURMYSQL

    Si les deux sont différents, ça expliquerait pourquoi le phpMyAdmin ne voit pas toutes les bases alors qu'il devrait. (Ou les deux n'ont pas le même mot de passe).

    L'alternative (en attendant la résolution via le support) est de créer un utilisateur MySQL (via le CPANEL) et de l'ajouter à toutes les bases. (Créer un administrateur finalement).

    D'installer (soit via Softaculous ou directement) un phpMyAdmin ou un truc plus simple, exemple SIDU http://topnew.net/sidu

    Et de se connecter avec l'utilisateur fraichement créé.
     
    Dernière édition: Fév 26, 2017
  6. Thanae

    Thanae New Member

    Merci pour vos réponse.
    Je ne m'était pas connecté depuis vendredi et maintenant, bizarrement, cela fonctionne, je vois mes db sous mon user principale.

    Par contre, je continue d'accumuler les problèmes:
    - perte de session non stop après 1 min ou dès que je change de panel (cpanel, phpMyAdmin, gestionnaire de fichier, Softaculous,...)
    - plus rien sous mon domaine (j'avais publier avec Site publisher le theme "En construction"), ni sous-domaine après install pour la énième fois de CMS made Simple
    donc là je contacte le support.
     

Partager cette page