problème de connexion a ma base de donnée

Discussion dans 'Discussions Générales' démarrée par magic_panda, Sep 3, 2012.

  1. magic_panda

    magic_panda New Member

    Bonjour,

    Lorsque je veux me connecter à ma base de donnée j'ai cette erreur:
    "Erreur : SQLSTATE[HY000] [2005] Unknown MySQL server host 'sql.planethoster.net' (1)"

    A mon avis il ne trouve pas le serveur, et donc après des recherche sur le net j'ai vu qu'il fallait mettre "localhost" pour l'hôte.
    Voici mon code:
    Code:
    $bdd = new PDO ('mysql:host=localhost; dbname=nom_de_la_bdd', 'nom_utilisateur', 'mot_de_passe');
    D'où proiens cette erreur?

    Merci d'avance
    Patrice
     
  2. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    TU as demander le pdo sur ton compte ?
     
  3. vincent

    vincent New Member

    Tu essaye de te connecter a partir de ton hebergement chez PH ou d'un autre hebergement ?
     
  4. magic_panda

    magic_panda New Member

    Bonjour,

    Je pensais que la PDO était activé automatiquement!!! Comment faire faire pour la demander je dois ouvrir un ticket?

    Je suis hébergé sous PlanetHoster!!!

    Merci de vos réponses
     
  5. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Le pdo est pas actif pas défaut, demande par ticket si il est actif sur ton serveur.
     
  6. magic_panda

    magic_panda New Member

    Ok merci, je fais la demande de suite.
     
  7. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour à tous,

    Normalement, PDO et PDO_MySQL sont actifs par défaut sur les mutualisés, revendeurs et e-commerce. Pour confirmer, vous pouvez faire un phpinfo .

    Bonne journée à tous,
     
  8. magic_panda

    magic_panda New Member

    Effectivement, PDO est bien activé par défaut!!! J4ai fais un ticket me reste plus qu'à attendre une réponse.
     
  9. pierre_kuhn

    pierre_kuhn New Member

    Quel est la référence du ticket ?
     
  10. magic_panda

    magic_panda New Member

    Voici la référence du ticket: XUV-571-52348

    Mais entre temps c'est bon j'ai résolu le problème.

    Merci de votre aide.
     
  11. pierre_kuhn

    pierre_kuhn New Member

    ok parfait

    Si tu as du temps pour un tuto sur PDO ça serait top ;)
     
  12. magic_panda

    magic_panda New Member

    J'aimerais bien faire un tuto sur PDO mais je n'ai pas les connaissances nécessaire la dessus.
    J'ai réalisé mon site via des tutos trouvés sur le net.
     
  13. pierre_kuhn

    pierre_kuhn New Member

    magic_penda tu avais un problème, tu l'a corriger
    Comment ? soucis de code ? ....

    Voilà c'est l'idée pour commencer
     
  14. magic_panda

    magic_panda New Member

    Bonjour,

    Ce n'était pas un problème de code, c'est encore plus bête que ça, au risque de passer pour un c*n lol:cool:

    La première fois que j'ai mis mon fichier en ligne j'avais remplaçais "localhost" par l'addresse de planethoster, ce qui n'allais pas. Et après des recherche sur le net j'ai vu qu'il fallait mettre "localhost" pour l'hôte. Donc j'ai fais ma modification. Et là lorsque je l'ai envoyé je me suis trompé de dossier pour mon fichier du coup le changement de fichier n'a pas été effectué.

    Par la suite lors de mes essaies je changeais toujours le mauvais fichier, et donc ça ne marchais jamais. Mais je n'y prêtais pas attention car a chaque fois je voyais le message de remplacement.

    Et en faisant une modification qui devais me sauté aux yeux, je me suis aperçu que la modification n'avais pas été apporter et c'est là que j'ai remarqué que je n'étais pas dans le bon dossier...

    Voilà pour l'histoire qui ne me permettra pas de faire un tuto... Et qui m'a appris à faire plus attention lors des envoie de fichier.

    Donc désolé du dérangement.:confused:
     
  15. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    merci pour le retour.

    Oui, faire un tuto sera dur. Moi je vais faire un avec les option qui sont activé par défaut.
     
  16. magic_panda

    magic_panda New Member

    Bonjour,

    Effectivement un petit sujet sur les option activé par défaut pourrais être bien utile.

    Merci

    Patrice
     

Partager cette page