Problème de connection mySQL ! could not find driver

#1
Bonjour à tous,
je ne sais plus vers qui me tourner pour trouver une solution. J'ai lu tout ce que les tutoriels de Planet Hoster avaient sur le sujet, mais rien n'y fait.
Je cherche à ce que les données de mon formulaire d'inscription client s'écrivent dans phpMyAdmin. En local tout fonctionne, mais sur l'hébergeur :(.
Quelqu'un a-t-il une idée ou rencontré le même problème ? Merci d'avance pour votre aide.


Voici mon code et comment j'ai configuré les valeurs :

<?php
// Noter ici que le mot "prefix" ici est un substitut de vrai.
$dsn = "mysql:db=prefix_admin&table=artistes;host=localhost:3306";
$user = "prefix_artists";
$password = "q+Q[Kpl0$}%o"; //le mot de passe utilisateur crée dans le cPanel

try {

$conn = new PDO ($dsn,$user,$password);


//echo "connexion établie ". nl2br("\n") ;
}

catch (PDOException $e) {


echo "connexion impossible : " . $e ->getMessage ();
}
 

kub1996

New Member
#2
Votre message d'erreur indique que ce pilote n'est pas disponible. Vérifiez que l'extension mysql est installée sur votre serveur. Installez le paquet php5-mysql si vous ne l'avez pas
 

PH-Marc-André.B.

Modérateur
Membre du personnel
#3
Bonjour,

Il est possible d'ajuster les drivers de connexion à MySQL dans les extensions PHP de votre panneau World >>> Langages >>> PHP sur un N0C ou encore dans la section Logiciel >>> Sélectionner une version de PHP sur un compte world cPanel,

Voici l'article de la base de connaissance qui décrit comment changer les options de son environnement PHP avec nos solutions d'hébergement World cPanel ou N0C:

https://docs.planethoster.com/guide...omment-modifier-les-valeurs-parametres-de-php
 
Haut