Php 5.4

Discussion dans 'Hébergements Mutualisés' démarrée par geof, Oct 17, 2013.

  1. geof

    geof New Member

    Bonjour,

    j'aimerai savoir si vous allez faire passer les mutualisés sous php 5.4 bientôt ?
    Elle intègre une nouvelle fonctionnalité très intéressante en POO (traits) et qui me permettrait de gagner un temps fou sur le développement de mon site

    cdlt
     
  2. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour,

    Bien sûr, c'est prévu pour très bientôt.

    Bonne journée à vous,
     
  3. geof

    geof New Member

    merci pour votre réponse rapide

    je dois pouvoir espérer cela sous combien de temps ? (devrais-je compter en semaine, semaineS ou mois ?)

    merci par avance
     
  4. PH-Saber

    PH-Saber Administrator Membre de l'équipe

    Bonjour,

    Ce sera la version par défaut avant Noël certainement.

    Bonne journée à vous,
     
  5. geof

    geof New Member

    merci pour vos réponses
     
  6. contremaitre

    contremaitre New Member

    Bonjour,
    Je suis toujours en PHP 5.3, et Noel comment à dater... quand est prévu la migration ?
    Merci
     
  7. pierre_kuhn

    pierre_kuhn New Member

  8. contremaitre

    contremaitre New Member

    Super merci.
    Ou est ce que je vois sur quel serveur je suis ?
     
  9. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Via le lien cpanel du compte client vous avez cela, sinon ouvrez un ticket on vous dira cela.
     
  10. stefde3

    stefde3 New Member

    Moi j'ai mieux encore ^^

    je code un site en POO sur un server privé qui est configuré en PHP 5.4, et quelle n'est pas ma surprise quand j'essaye de l'héberger sur mon domaine multualisé : Rien que des erreurs de session_start() et headers aloready sent alors que sur mon server .... tout marche parfaitement sans aucune erreur.

    Là je passe par le tchatLive qui n'est naturellement pas assez compétent, et j'ouvre donc un ticket support... après quelques échanges voici la réponse finale :

    Voilà donc je dois modifier mon code donc dans un premier temps car c'est lui qui n'est pas bon... curieux puisqu'il fonctionne chez moi sur mon server...

    il me dit aussi que ma version PHP 5.4 n'est pas activé car cela est déprécié... je commence à me dire que soit il sait pas de quoi il parle, soit il s'est un peu emmêlé les pinceaux là...
    Pour les globals c'est normal puisque j'en utilise vu qu'il va s'agir d'une énorme plateforme.

    Bref je vérifie donc avec un petit phpinfo() et là surprise ^^ je suis sous PHP 5.4.

    Voilà donc pas de réponse claire, seulement des solutions à la mord-moi le noeud qui va me coûter, alors que tout devrait fonctionner puisque chez moi, j'ai un server privé configuré à PHP 5.4 et PHP 5.5 (en prévision) et il tourne très bien... Allez comprendre pourquoi ils ne veulent pas régler ce soucis d'erreurs intempestives. Je pense qu'il y a des modules de php non activé sur les servers qui font qu'on peut pas faire ce qu'on veut chez les hébergeurs en règle générale...

    Bref si d'ici la fin de la semaine le problème n'est aps résolu, bye bye Planethoster et les 4 sites que j'y héberge.
     
  11. PH-Jay

    PH-Jay Member

    Veuillez noter que si cela fonctionne chez vous c'est que vous avez surement installer des modules qui accepte les register global et session_start alors que ces fonctions on été supprimé de PHP 5.4 pour des raisons de sécurité :

    http://www.php.net/manual/fr/function.session-register.php
    PHP: Using Register Globals - Manual

    Veuillez aussi noter que la version PHP 5.3 est maintenant obsolète et elle est maintenant en "end of life" et ne sera plus supporté par la communauté PHP ce qui fait que cette version de PHP est totalement non sécuritaire:

    PHP: PHP 5.3.20 Release Announcement

    Veuillez SVP vous référer à ce document pour les changement à la version de PHP 5.4:

    PHP: Ce qui a changé dans PHP 5.4.x - Manual

    Veuillez noter que les fonctions register_global et session_start() ne pourront malheureusement pas être activé sur tous l'hébergement car ces 2 fonctions cause de graves problème de sécurité :

    What is register_globals and why is it a security risk? | Tournas Dimitrios

    Je vous encourage fortement à modifier votre application afin d’empêcher votre site d'être hacker.

    Veuillez aussi prendre note que si vous ne désirez pas faire ces modifications, vous pourrez être migrer vers un autre serveur qui possède l'option d'utiliser la version de PHP que vous désirez. Le coût de cette migration est de 12 euros et aucune coupure n'est à prévoir et il nous fera plaisir après la migration de vous mettre votre compte en PHP 5.3

    Je comprend totalement votre insatisfaction, cependant il est important de toujours tenir vos application à jour en fonction des évolution proposé par PHP car ces modifications sont là pour protéger vos applications d'éventuels Hackers.

    Votre satisfaction est notre priorité.
     

Partager cette page