module-mod_rewrite

Discussion dans 'Hébergements Mutualisés' démarrée par rigness, Jan 9, 2014.

  1. rigness

    rigness New Member

    Bonjour,

    J'ai lu dans les forum que le module était activé pour les hébergement mutualisés mais lorsque j'active
    les fonction de la gestion des url propre avec spip cela ne fonctionne pas.
    Si qq un peut m'aider.
     
  2. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Rigness,

    Effectivement le mod_rewite de Apache n'est pas installé sur les serveurs mutualisés, car nous n'utilisons pas Apache mais bien LiteSpeed qui est près de 9 fois plus rapide que le service WEB Apache,

    Cependant la réécriture d'URL (URL-Rewriting) fonctionne très bien sur nos serveurs via les mêmes règles présentes dans votre fichier .htaccess,

    Vous pouvez le rester en faisant un fichier .htaccess dans le public_html avec ceci:

    Code:
    RewriteEngine On
    RewriteRule ^page-seo.html$ page-serveur.html [L]
    Vous pourrez appeler dans problème http://www.domaine.com/page-seo.html et cela appellera le fichier page-serveur.html présent sur le serveur

    Pouvez-vous ouvrir un ticket afin que l'on vous accompagne dans la recherche du non-fonctionnement de SPIP?

    Cordialement,
     
  3. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    La réécriture des url avec le htaccess par défaut de spip fonctionne parfaitement.
    Quel type d'url bloque ? Quelle version de spip ?
     
  4. rigness

    rigness New Member

    Bonjour,

    Merci pour votre réponse, je vais tester ça et ouvre un ticket.

    Bien à vous.
    Patrice

    SPIP 3.0 et tout type d'url.
     
  5. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Vous avez renommer le htaccess en .htaccess ?
     
  6. rigness

    rigness New Member

    Bonjour,

    J'au bien nommé le fichier en .htacces en mettant ce que avez indiqué plus haut.
    Voici les différents types, j'ai testé avec plusieurs, y a t-il une récritrure d'url spécifique à utiliser.

    URLs Arborescentes
    /article/titre

    URLs Historiques
    article.php3?id_article=12

    URLs Libres
    Titre-de-l-article Rubrique

    URLs Objets HTML
    article12.html

    URLs Page
    spip.php?article12

    URLs Propres
    Titre-de-l-article -Rubrique-

    URLs Propres en query-string
    ?Titre-de-l-article

    URLs Propres+.html
    Titre-de-l-article.html -Rubrique-.html

    URLs Simples
    spip.php?page=article&id_article=12

    Merci par avance
    Patrice
     
  7. rigness

    rigness New Member

    ça fonctionne, je ne sais pas pourquoi cela ne fonctionnait pas :)

    En tout cas merci pour votre aide

    Patrice
     
  8. pierre_kuhn

    pierre_kuhn New Member

    De rien, un problème de cache ?
     
  9. rigness

    rigness New Member

    Bonjour,

    Oui certainement :)
    Par contre seules les URLs Propres en query-string
    ?Titre-de-l-article fonctionnent.

    Y a t-il un moyen de faire fonctionner les url propres comme URLs du style Propres+.html
    Titre-de-l-article.html -Rubrique-.html par ex.

    qui elles ne fonctionnent pas.

    Cordialement,
    Patrice
     
  10. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Sur quel site ? cela est pas logique, toutes fonctionnent.
     
  11. rigness

    rigness New Member

    dans mon publihtml c'est le dossier librairie
     
  12. pierre_kuhn

    pierre_kuhn New Member

    Sur irc je dirais @url, sans domaine je peux pas vous trouvez ;)
     
  13. rigness

    rigness New Member

    dans mon publichtml c'est le dossier librairie
     
  14. rigness

    rigness New Member

    ? je n'ai pas bien compris votre réponse
     
  15. pierre_kuhn

    pierre_kuhn New Member

    oui mais sur quel domaine ?
     
  16. rigness

    rigness New Member

    paris-livresanciens.com
     
  17. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Vous pouvez modifier le type d'url dans la base ?
     
  18. rigness

    rigness New Member

    Bonjour Pierre,
    C'est à dire exactement ?
     
  19. pierre_kuhn

    pierre_kuhn New Member

    oui, je le fais en version longue, dans spip changez le type d'url svp.
    En mettant celle qui fonctionnais pas.

    Vous débutez en spip non ?
     
  20. rigness

    rigness New Member

    OK, je connais spip, mais je l'avoue j'ai quelques lacune pour les url rew..:)
    Alors là pour le coup vous devez avoir un bon fluide car les url propres se mettent à fonctionner d'un coup :)
    Pour infos j'ai désactivé le cache et je me demande si ce n'est pas ça qui déconnait...
    En tout cas merci pour votre aide précieuse.

    Patrice
     
  21. pierre_kuhn

    pierre_kuhn New Member

    Non j'ai modifier le htaccess, a vous de pas l'écraser maintenant.
    hésitez pas à demander via ticket ou ici si vous avez besoin.

    Je ferme ce fil car il est résolu.
     

Partager cette page