mise a jour site

Discussion dans 'Discussions Générales' démarrée par khratz, Nov 8, 2012.

  1. khratz

    khratz New Member

    Bonjour, voila je suis nouveau dans le monde de la programmation et donc il y'a beaucoup de choses que j'essaye de comprendre. J'ai acheté un nom de domaine, je me suis connecté a mon site par FTP via filezilla et j'ai donc upload mes fichiers .html et .css. Quand j'ouvre ses fichiers sur mon pc via un navigateur, chrome dans mon cas, le site
    s'affiche comme je l'ai codé, parfait. Mais quand je l'ouvre directement a partir du web avec donc les même fichiers
    téléchargé par filezilla, mon site a une tout autre apparence. Et je ne vois pas du tout comment faire pour qu'il
    apparaisse comme je le souhaite. Si quelqu'un pourrait me donner plus de renseignements.

    Merci d'avance.
     
  2. David77

    David77 Member

    Bonjour,
    Une URL pour tester ?
    Ce ne serait pas un problème de chemin dans tes fichiers?
     
  3. khratz

    khratz New Member

  4. David77

    David77 Member

    Bon j'ai jetté un coup d'oeil sur ton code....
    Il manque des choses...

    HTML:
    <html>
        <head>
            <meta charset="utf-8" />
    		<link rel="stylesheet" href="style.css" type="text/css" charset="utf-8" />
    	    <script type="text/javascript" src="jquery.js"></script>  
            <script type="text/javascript" src="sliding_effect.js"></script>  
    		<title>KhratZ & Co</title> 
        </head>
    
        <body>
    		</br>
    		<header> KHRATZ & CO 
    		</br>
    		
    		<div id="navigation-block">  
                <ul id="sliding-navigation">  
                    <li class="sliding-element"><h3>KHRATZ & CO</h3></li>  
                    <li class="sliding-element"><a href="404.html">404</a></li>  
                    <li class="sliding-element"><a href="videos.html">VIDEOS</a></li>  
                    <li class="sliding-element"><a href="#">Link 3</a></li>  
                    <li class="sliding-element"><a href="http://xxxxxxxx.com" target="_blank">TUMBLR</a></li>  
                    <li class="sliding-element"><a href="mailto:xxxxxxxxxx">MAILME</a></li>  
                </ul>  
            </div> 
    		
    		<img src="img/121101-002658.jpg" />
    		</br>
    		</br>
    		<img src="img/lisamoustache.jpg" />
    		</br>
    		
    	
    		
        </body>
    </html>
    Par exemple ici :
    Code:
    <header> KHRATZ & CO 
    Rien en te choque?

    Idem au tout début de ton code tu as
    Code:
    <!DOCTYPE html>
    C'est pas suffisant...

    Et ton fichier CSS contient des déclarations en 4 ou 5 fois.....
     
  5. khratz

    khratz New Member

    Je comprend qu'il y'a plein de fautes, ça doit faire une semaine que je touche au html.

    HTML:
    <header> KHRATZ & CO
    donc ici il faut que je rajoute </header> a la fin ?

    Puis pour le doctype, j'ai lu que pour le html 5 il suffisait juste de mettre ça
    HTML:
    <!DOCTYPE html>
    Puis quand tu parle de mes déclarations répétées, tu parle des </br> ?

    Et en fait je me suis rendu compte que le design s'affiche très bien sur mon iphone, alors que sur chrome non.
     
  6. pierre_kuhn

    pierre_kuhn New Member

    Si tu maitrises pas le html regarde le site du zero ou bien part d'un cms ainsi tu t’embêtera moins
     

Partager cette page