LiteSpeed / Apache 2.x

Jessy

New Member
#1
Bonsoir...

Peut-on savoir si la version de LiteSpeed correspondrait plutôt à un Apache v2.2 ou v2.4 au niveau de certains paramètres ?

Par exemple, je voulais appliquer cela

Code:
# Block access to files that can expose sensitive information.

# By default, block access to backup and source files that may be left by some
# text editors and can pose a security risk when anyone has access to them.
# http://feross.org/cmsploit/

# IMPORTANT: Update the `<FilesMatch>` regular expression from below to include
# any files that might end up on your production server and can expose sensitive
# information about your website. These files may include: configuration files,
# files that contain metadata about the project (e.g.: project dependencies),
# build scripts, etc..

<FilesMatch "(^#.*#|\.(bak|config|dist|fla|in[ci]|log|psd|sh|sql|sw[op])|~)$">

    # Apache < 2.3
    <IfModule !mod_authz_core.c>
        Order allow,deny
        Deny from all
        Satisfy All
    </IfModule>

    # Apache ≥ 2.3
    <IfModule mod_authz_core.c>
        Require all denied
    </IfModule>

</FilesMatch>
Voilà, ça vient de H5BP
https://github.com/h5bp/server-configs-apache

C'est plus par curiosité ;-) que autre chose

Pas très important dans notre cas! mais je me demandais et je ne trouve pas d'info à ce sujet
 
#2
on le sais jamais ,j ai deja poser cette question il reponde qui sont a jour par contre nous on le voit pas aucun log de version nous appartiens de voir, d ailleurs ce pas conforme a la loi si une société nous oblige un logiciel on devrais connaitre sa version actuelle.
 

pierre_kuhn

New Member
#3
Bonjour

Les serveurs tournent sur apache 2.2 mais comme vous avez litespeed je ne sais pas si le htaccess vous remonte la version.
 

PH-Jay

Member
#4
on le sais jamais ,j ai deja poser cette question il reponde qui sont a jour par contre nous on le voit pas aucun log de version nous appartiens de voir, d ailleurs ce pas conforme a la loi si une société nous oblige un logiciel on devrais connaitre sa version actuelle.

Je suis désolé, mais votre réposne est tottalement fausse. Veuillez noter que vous pouvez toujours utiliser un PHP info pour voir les version des logiciels installé.
 

Jessy

New Member
#5
En tout cas pour revenir au sujet ;-) ce n'est pas un phpinfo qui va m'eclairer...

Merci @Pierre on va essayer en supposant que cela correspond à un Apache 2.2 et à défaut nous restera à tester l'autre syntaxe ;-) ça sera aussi rapide à faire que à écrire ici
 
Haut