Installation Redmine

Discussion dans 'Hébergements Mutualisés' démarrée par romain-d, Mai 9, 2014.

  1. romain-d

    romain-d New Member

    Bonjour,

    Je dispose d'un hébergement mutualisé. Ceux ci étant compatible avec Ruby on Rails, je souhaiterai réaliser l'installation de Redmine.

    J'ai l'accès SSH au serveur et j'ai déjà testé quelques installation, mais rien n'y fait impossible d'aboutir à quelque chose. Je n'ai pas de grandes connaissances en admin serveur et en Ruby, mais je sais me débrouiller.

    Est ce que quelqu'un a déjà réussi cette installation ? Je n'ai pas trouvé d'autres sujets ou aide parlant de cette installation.

    Merci d'avance.

    Cordialement,

    Romain.
     
  2. lxwfr

    lxwfr New Member

    pas testé, ta une exemple d'installation ici https://github.com/liliff/web/blob/master/_posts/2013-02-26-installing-redmine-1.4-on-cpanel-shared-hosting.md
     
  3. romain-d

    romain-d New Member

    Merci de votre lien, je n'étais pas tombé dessus.

    Malheureusement, je ne peux pas lancer la commande "bundle install --without development test postgresql sqlite" il me dit que la commande est introuvable.

    Pourtant bundler est bien installé via Cpanel.

    Je me demande si ce n'est pas la configuration du .gemrc qui n'est pas bonne sur le tutoriel (je pense que l'arborescence a changé depuis).

    Par exemple sur le tuto, je dois ajouter cette ligne au bash_profile : export GEM_HOME=$HOME/.gem/ruby/1.8
    Or dans le dossier ".gem" il n'y a pas de dossier "ruby"

    Ou bien est ce que les accès SSH PlanetHoster nous permettent de lancer les commandes bundle ?
     
    Dernière édition: Mai 10, 2014
  4. lxwfr

    lxwfr New Member

    si non il y a des alternative sans se casser la tête comme start - Flyspray - The Bug Killer! ou autre....
     
  5. romain-d

    romain-d New Member

    Merci pour le lien, je ne connaissais pas cet outil.

    Malheureusement nous sommes habitués à utiliser Redmine et vu que les hébergements de PlanetHoster sont censés être compatibles...

    A savoir que je n'arrive pas à lancer des "bundle install", que ce soit dans mon dossier Redmine ou encore dans un projet Rails créé par CPanel.

    Je pense que ça doit venir de la configuration des variables d'environnement, si quelqu'un a une idée ou si un admin de chez PlanetHoster passe dans le coin.
     

Partager cette page