installation automatique prestashop 1.2.5.0

zeiss

New Member
#1
Bonjour,

Je pense commandé un espace mutualisé sur planethoster.

Avant ,je voudrais savoir si-il existe une installation automatique d'une boutique e-commerce "Prestashop" 1.2.5.0 ou un mode d'emploi pour mon transfert en local sur "wampserver" vers planethoster?

merci

bonne journée
 

jacobis

New Member
#2
Prestashop

Bonjour,
Prestashop a déja un mode d'installation automatique, il faut toutefois créer au préalable une base de donnée. L'install est simple et sans problèmes.
Pour la seconde question, il suffit de chercher sur le forum prestashop, c'est un sujet qui a été abordé de nombreuses fois.
 

zeiss

New Member
#3
Merci pour ta réponse,

La boutique est déjà créer en local avec wamperver sur mon PC, je voudrais la transférer sur Planethoster, mais je trouve pas df'information sur le site!

(comment mettre en production "sur serveur") une boutique crée en local)

Je connais le principe de base, il faut transférer via FTP le dossier prestashop, il faut aussi transférer la base de donnée, mais comment faire, comment relier les fichiers à la base....

Je ne trouve pas l'information ou un pas a pas sur le site

Certain hébergeurs propose,une installation automatique..

Bonne soirée
 

jacobis

New Member
#4
Bonjour,
I faut envoyer sur le serveur l'ensemble des fichiers et dossiers puis importer la base de données.

Comme le script tournait en local, les infos de connection à la BD sont obsolètes, il faut donc renseigner le fichier: settings.inc.php (situé dans le dossier config) en lui donnant les bonnes infos.

define('__PS_BASE_URI__', '/');
define('_THEME_NAME_', 'Le nom du theme');
define('_DB_NAME_', 'Le nom de la BD');
define('_DB_SERVER_', 'localhost');
define('_DB_USER_', 'Le Login permettant d'accéder à la BD');
define('_DB_PREFIX_', 'Le préfixe des tables (défini lors de la création de la BD');
define('_DB_PASSWD_', 'Mot de passe pour se connecter à la BD');
define('_DB_TYPE_', 'MySQL');

*Pour le reste pas de changements.
Il peut y avoir un problème avec les images (il est préférable de les régénerer depuis l'admin ou back office.
Si malgré la régénération le problème persiste, vérifier le chemin des images.
 
Haut