Forcer WordPress en "https" soucis connexion back-office

plwebdev

New Member
#1
Bonjour à tous,

J’ai ajouté « https://… » dans la table « wp_options » de mon site internet, mais je rencontre désormais un problème pour me connecter au back-office…

Je tombe désormais sur une erreur 401, et sur une pop-up qui me demande des identifiants que je ne connais pas.

J’ai suivi ce tutoriel Planethoster :

https://docs.planethoster.com/guide...le-htaccess/comment-passer-wordpress-en-https

J’ai même ajouté le plugin « SSL Insecure Content Fixer » mais cela ne change rien.

Par contre que je retire le « s » dans « wp_options » la page de login WordPress revient bien comme avant, mais en "http".

Avez-vous déjà eu ce problème ?

Merci pour votre aide.
 

Fichiers joints

PH-Marc-André.B.

Modérateur
Membre du personnel
#2
Bonjour,

Vérifiez votre cPanel >>> PH-Tools >> CMS Protection ainsi que votre fichier .htaccess
 

plwebdev

New Member
#4
Bonjour PH-Marc-André.B.

Je suis allé dans cPanel >>> PH-Tools >> CMS Protection, et l'option été activée.

Je l'ai désactivée puis je suis retourné dans PHPmyAdmin pour rajouter https dans siteurl et home de la ma table wp_options et cela marche bien désormais, j'arrive à accéder au back-office WordPress en https sans problème.

Vous trouverez ci-joint une capture de mon fichier .htaccess, dois-je y ajouter quelque chose ? Je n'y ai pas touché.
 

Fichiers joints

PH-Marc-André.B.

Modérateur
Membre du personnel
#5
Bonjour,

Ceci correspond bien à un .htaccess minimal pour pouvoir gérer un WordPress!

Tout compte fait nous recommandons fortement de garder notre protection CMS active parce qu'elle va mettre à contribution le pare-feu CSF du serveur pour vous aider avec la sécurité WP.

Autrement nous vous recommandons d'installer un bon plugin de FireWall applicatif tel que WordFence premium ou encore SecuPress.
 
Haut