Error establishing a database connection

Discussion dans 'Hébergements Mutualisés' démarrée par Zvedj, Mai 25, 2015.

  1. Zvedj

    Zvedj New Member

    Bonsoir, J'ai fais mon site en localhost avec MAMP sur Wordpress, après avoir finit mon site j'ai donc voulu le placer en ligne en choisissant PlanetHoster.

    Avec filezilla j'ai pu upload mon fichier du site sur le serveur
    [le dossier de mon wordpress est 'rages' j'ai donc placé 'rages' directement dans "public_html"]
    , hors quand je vais sur mon site
    "www.raygeez-design.com" je n'atteins même pas le visuel de mon site mais un "index of/" avec cgi-bin et mon site "rages" ce qui déjà n'est pas bon.

    Ensuite, si je clique sur le dossier de mon site je suis redirigé sur un blank " Error establishing a database connection " avec ce message.

    J'ai passé la journée et toute ma soirée à chercher sur le forum, google et j'ai même contacter le support via chat en direct.
    Ce qu'il en est ressortie est que je n'avais pas créer ma BDD (base de donné) sur le Cpanel.
    Après quelques minutes je fais ma BDD sur Cpanel et mon utilisateur avec tout les droits et importe ma BDD du local host dans celle créer dans le Cpanel.
    je test une nouvelle fois et aucun résultat.

    Je me dis alors que ça viens d'un soucis de "login" je vais donc dans mon wp_config.php et change donc les name/password/bdd et host que j'avais en localhost par les nouveaux de la base de donné Cpanel.
    toujours pas de résultat positif.

    Sur mon wordpress localhost ma base de donné était BDD/rages_bdd
    sur PH je n'ai pas le choix de la bdd , elle commence obligatoirement par raygkann_ ce peut il que ce soit le problème?

    J'ai mon concours la semaine prochaine et je suis donc un peu STRESSER haha

    Je pense ne rien avoir oublier dans les détails, sauvez moi :eek:
    Merci d'avoir pris le temps de lire.
     
    Dernière édition par un modérateur: Déc 8, 2017
  2. PH-Gabriel

    PH-Gabriel Moderateur Membre de l'équipe

    Bonjour,

    Suite à notre conversation sur le chat, il semble que le problème est en voie d'être corrigé.

    Si vous rencontrez de nouveaux problème, je vous invite à nous contacter soit via le chat ou par le système de ticket (https://www.planethoster.com/fr/Contact).

    Au plaisir de vous aidez à nouveau.
     
  3. Zvedj

    Zvedj New Member

    suite à votre aide Ph-Gabriel :

    Le DB_HOST de wp-config doit être "localhost" ( il était www.raygeez-design.com )

    -------------------

    mon site était apparût, mais j'avais toujours l'index of/ au lieu d'arriver directement sur ma page d'accueil et mes autres pages ne fonctionnaient pas.

    Vous m'avez donc expliquer que ceci était normal puisque je j'avais changer mon url du site et m'avez invité à déplacer mes fichier dans le dossier public_html et non dans le dossier rages.
    Puis par la suite de me connecter à mon wp-login et dans les paramètres changer le lien de mon site.

    j'ai donc placer mes "wp-admin" "wp-content" et "wp-include" directement dans public_html,
    je suis ensuite allé dans mon wordpress, paramètres et j'ai changer donc l'adresse du site "http://localhost/rages" par "http://www.raygeez-design.com".

    Maintenant :
    l'adresse de mon site m'envois toujours vers "index of/", on y trouve "wp-admin" "wp-content" et "wp-include". Je dois donc toujours faire quelque chose mal.

    De plus je n'arrive plus à me login :
    http://www.raygeez-design.com/wp-admin/

    réponse :
    Warning: require_once(/home/raygkann/public_html/wp-load.php): failed to open stream: No such file or directory in /home/raygkann/public_html/wp-admin/admin.php on line 31

    Fatal error: require_once(): Failed opening required '/home/raygkann/public_html/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/raygkann/public_html/wp-admin/admin.php on line 31

    EDIT
    Le soucis viendrait des fichier qui se serait mal upload, je suis donc actuellement en train de tout r'envoyer au serveur.
    Je tiens a remercier le support qui est vraiment très efficace et rapide.
     
    Dernière édition par un modérateur: Déc 8, 2017
  4. PH-Gabriel

    PH-Gabriel Moderateur Membre de l'équipe

    Les fichiers de base wp-load.php, wp-config.php, index.php, etc ne sont pas présent dans votre public_html.

    Je vous invite donc à les transférer à nouveaux.

    Votre satisfaction est notre priorité.
     
  5. Zvedj

    Zvedj New Member

    oui désolé j'ai pris le temps de tout refaire comme il faut.

    ma page d'accueil est en ligne, mais les autres pages semble ne pas répondre, cela m'affiche :
    Not Found

    The requested URL /index.php was not found on this server.

    Pourtant dans mon content j'ai bien un index.php.
     
  6. PH-Gabriel

    PH-Gabriel Moderateur Membre de l'équipe

    Vous devez changer les paramètres de Wordpress pour que Wordpress utilise raygeez-design.com.

    Connectez-vous à votre WP-Admin et allez dans l'option Réglages > Général.

    Par la suite dans la case "Adresse web de WordPress (URL)" et "Adresse web du site (URL)" vous devez mettre le nouveau lien de votre site internet.

    Donc dans votre cas: http://raygeez-design.com/
    Ou si vous voulez utiliser le www: http://www.raygeez-design.com/

    Cliquez sur "Enregistrer les modifications" pour terminer.

    Votre satisfaction est notre priorité.
     
    Dernière édition par un modérateur: Déc 8, 2017
  7. Zvedj

    Zvedj New Member

    comment j'accède à mon wordpress via le serveur ?
    car quand j'ouvre mon site sur une page internet soit : http://www.raygeez-design.com
    et que je souhaite me connecter à mon wordpress pour modifier les réglages et tape donc :
    http://www.raygeez-design.com/wp-admin ce qui m'envois sur

    http://localhost/rages/wp-login.php?redirect_to=http://www.raygeez-design.com/wp-admin/&reauth=1

    pourquoi http://localhost/rages ?

    si je modifie ici cela va affecter mon localhost et non pas le site host sur PH.

    c'est donc là que mon soucis ce trouve depuis ce matin.
     
  8. PH-Gabriel

    PH-Gabriel Moderateur Membre de l'équipe

    Pouvez-vous vider la cache de votre navigateur svp?

    Google Chrome
    > Paramètres > Afficher les paramètres avancés… > Effacer les données de navigation > cochez "vider le cache" , décochez les autres si vous le souhaitez > Cliquez sur "Effacer les données de navigation"

    Firefox
    > Options > Réseau > contenu web en cache > Vider maintenant

    Internet Explorer
    > Options > Sécurité > Supprimer l'historique de navigation > Supprimer


    Par la suite, utilisez le lien suivant pour vous connecter: http://www.raygeez-design.com/wp-login.php

    Si cela ne fonctionne pas, je vous invite à ouvrir un ticket en nous donnant les identifiants de votre WP-Admin pour que je regarde le problème avec vous.
     
  9. Zvedj

    Zvedj New Member

    Merci pour votre support très rapide et efficace, Le problème est résolu.

    Grâce aux étapes fournis.
     

Partager cette page