Erreur 406

Steeve G

New Member
#1
Bonjour,

Je me permet de vous écrire parce que je rencontre une erreur que je ne comprend pas.
Quand je fais certaines chose sur ma page web j'ai le message ci-dessous qui apparait, après vérification et remplacement du fichier soit-disant manquant, le problème persiste.
Pouvez-vous me dire l'origine du problème s'il vous plait ?

Cordialement

Steeve

Message d'erreur :
Not Acceptable
An appropriate representation of the requested resource /mail_send.php could not be found on this server.
Additionally, a 406 Not Acceptable error was encountered while trying to use an ErrorDocument to handle the request.
 
#2
Bonjour,
Effectivement une erreur pas connue pour ma part lol

En cherchant sur google on trouve ceci comme explications possibles :
Le code de réponse d'erreur HTTP 406 Not Acceptable indique qu'il est impossible de servir une réponse qui satisfait aux critères définis dans les en-têtes Accept-Charset et Accept-Language.
En réalité, cette erreur est très rarement utilisée. Plutôt que de répondre avec ce code, incompréhensible de l'utilisateur (et difficile à résoudre), les serveurs ignorent les en-têtes en question et renvoient une page à l'utilisateur. On part du principe que, même si l'utilisateur ne sera pas complètement satisfait, ce scénario est préférable à un code d'erreur.
Si un serveur renvoie ce code d'erreur, le corps du message doit contenir la liste des représentations disponibles pour cette ressource afin de pouvoir choisir manuellement parmi celles-ci.
Site de Mozilla

Peux-tu nous mettre le code de ton fichier d'envoie d'email ?
 

PH-Gabriel

Moderateur
Membre du personnel
#3
Bonjour Steeve,

Les erreurs 406 sont souvent causées par le module de sécurité modsec. Il est possible que ce soit un faux positif.

Il sera possible de désactiver modsec via votre cPanel afin de tester.
 

Steeve G

New Member
#4
Bonjour,
Effectivement une erreur pas connue pour ma part lol

En cherchant sur google on trouve ceci comme explications possibles :

Site de Mozilla

Peux-tu nous mettre le code de ton fichier d'envoie d'email ?
Voici le code du fichier.

Petite précision, ce n'est pas une base que j'ai créer, mais une base en open source pour la gestion de casernes de pompiers et associations de secourisme, je ne l'ai que l'installé et l'utilisateur.
Je rencontre le même problème avec d'autres rares page de ma base.

Merci beaucoup.

Steeve

<?php
# project: eBrigade
# homepage: http://sourceforge.net/projects/ebrigade/
# version: 4.4

# Copyright (C) 2004, 2018 Nicolas MARCHE
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

include_once ("config.php");
include_once ("fonctions_sms.php");
check_all(43);
$id=intval($_SESSION['id']);
$mysection = $_SESSION['SES_SECTION'];
writehead();

$dest=$_GET["dest"];
$mode=$_GET["mode"];

if ( isset ($_GET["subject"])) $subject=clean_mail_data($_GET["subject"]);
else $subject = "";

if ( $mode == 'sms' ) check_all(23);

$message=clean_mail_data($_GET["message"]);

if ( $mode == 'sms' ) {
$sent = send_sms ( "$id", "$dest", "$message", "$mysection", "mail_create.php?mode=sms" );
}
else {
if ( $subject == "") $subject="message de ".ucfirst(get_prenom($id))." ".strtoupper(get_nom($id));
$nb = mysendmail( "$dest" , $id , $subject , "$message" );

write_msgbox("OK", $star_pic, "Le message a été envoyé à:
<br>".$nb." personnes<p><font face=arial size=2>Sujet:[".$cisname."] ".$subject."
<p>".nl2br($message)."</font><p align=center><a href='index.php'><input type='submit' class='btn btn-default' value='Retour'></a>",30,0);
 

Steeve G

New Member
#5
Bonjour Steeve,

Les erreurs 406 sont souvent causées par le module de sécurité modsec. Il est possible que ce soit un faux positif.

Il sera possible de désactiver modsec via votre cPanel afin de tester.
J'ai eu dû mal à trouver le modSecurity, mais effectivement, une fois désactivé, je n'ai plus le message d'erreur !!!!

Que dois-je faire ? Le laisser désactivé ?

Merci

Steeve
 

PH-Gabriel

Moderateur
Membre du personnel
#6
J'ai eu dû mal à trouver le modSecurity, mais effectivement, une fois désactivé, je n'ai plus le message d'erreur !!!!

Que dois-je faire ? Le laisser désactivé ?

Merci

Steeve
Malgré que modsec protège contre plusieurs attaques, il est possible qu'il ne soit pas compatible avec certains sites.

Tant que vous gardez votre site internet à jour et que vous appliquez les bonnes pratiques de programmation en matière de sécurité, ce module ne sera pas nécessaire. Vous pouvez le désactiver pour ce domaine seulement.
 

Steeve G

New Member
#7
Malgré que modsec protège contre plusieurs attaques, il est possible qu'il ne soit pas compatible avec certains sites.

Tant que vous gardez votre site internet à jour et que vous appliquez les bonnes pratiques de programmation en matière de sécurité, ce module ne sera pas nécessaire. Vous pouvez le désactiver pour ce domaine seulement.
Merci pour votre réponse,

Comme dis plus haut, je ne suis pas concepteur "du site" en faite, c'est une base de donnée en ligne pour une association.
Elle n'est pas répertorié sur google et peu de personne l'utilise et connaisse son adresse (environ 30).
Quand vous dite "pour ce domaine" vous parlez du site en entier ou juste la page en question ?
Pour uniquement retirer la protection sur une page je ne sais hélas pas faire !!!

Cordialement

Steeve
 

PH-Gabriel

Moderateur
Membre du personnel
#8
Merci pour votre réponse,

Comme dis plus haut, je ne suis pas concepteur "du site" en faite, c'est une base de donnée en ligne pour une association.
Elle n'est pas répertorié sur google et peu de personne l'utilise et connaisse son adresse (environ 30).
Quand vous dite "pour ce domaine" vous parlez du site en entier ou juste la page en question ?
Pour uniquement retirer la protection sur une page je ne sais hélas pas faire !!!

Cordialement

Steeve
Quand je dis "pour ce domaine", je parle du site en entier. Vous pouvez donc désactiver pour un seul domaine via l'option modsec du cPanel. Cette option n'offre pas la possibilité de désactiver pour une page seulement.

Je reste disponible si vous avez d'autre questions.
 

Steeve G

New Member
#9
Quand je dis "pour ce domaine", je parle du site en entier. Vous pouvez donc désactiver pour un seul domaine via l'option modsec du cPanel. Cette option n'offre pas la possibilité de désactiver pour une page seulement.

Je reste disponible si vous avez d'autre questions.
Merci beaucoup pour votre aide.

Steeve Gillig
 
Haut