erreur 404 sur WAMP uniquement

Discussion dans 'Discussions Générales' démarrée par sensei-kuma, Avr 22, 2012.

  1. sensei-kuma

    sensei-kuma Member

    je voudrais que l'on m'explique pourquoi des pages fonctionnent sur wamp
    et font des erreurs 404 des qu'elles sont sur le serveur ?
     
    Dernière édition: Avr 23, 2012
  2. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Peux tu regardez ton ticket ?
    Ensuite faire des liens vers un wp ne sert à rien si tu l'installe pas ...
     
  3. sensei-kuma

    sensei-kuma Member

    C'est pas le wp qui déconne
    c'est nogizaka46 dont l'ensemble du lien est pourtant bon

    et snh48/snj48 au second et ca n'a jamais existez

    le 3eme lien lui a fonctionné.....alors une nuit blanche + aujourd'hui jusqu'à 4 heures avec cpanel ou mon ftp c'est pareil.

    Arrête de craner et avouez que y'a une couille quelque part que vous savez pas réparer.

    Quans à des futures lignes en prévision d'insertion d'un lien cers un wordpress c n'a jamais empeché un programme de fonctionner puisque c'est vide il pas donc outre
     
  4. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    Non je crane pas, si mes souvenir son bon tu as développer un formulaire php que David77 à du te corriger en plusieurs points.
    Ensuite "Nogizeka46 Les News du jour" renvoie vers la page sommaire du site comme pas mal d'autre de tes pages (tous les liens vers les pages de ce paragraphe sont pas correcte)

    Pour "Les Nogizaka46" il manque le nom du dossier dedans.

    Donc soit tu code mal soit tu sais pas développer correctement un site, alors passe sur wp ou un autre cms et le travail va se faire seul.
     
  5. David77

    David77 Member

    Bonjour Sensei.

    Tout d'abord je te le redis et j'insiste bien : une erreur 404 n'a rien à voir avec un problème de serveur !

    Une erreur 404 est du à un mauvais lien, un fichier inexistant, un dossier inexistant ou à un problème avec url rewriting.

    Tu n'utilise pas cette option donc ton erreur 404 provient d'une erreur de lien.

    Tu t'es lancé dans un projet complexe avec des sous-dossiers pour des parties de ton site, et donc ce genre d'erreur arrive.

    Avec un CMS (quelqu'il soit) tu aurais pu organiser tes parties en "catégories" et ainsi tes publications auraient été classées sans rien faire (et surtout pas du code).

    Pour résoudre ton problème il faut analyser comment ton erreur arrive : page de départ, quel lien est cliqué, là où tu arrives (adresse marqué dans ton navigateur) et là où tu voulais arriver.
    A partir de ça tu rectifie le lien en conséquence sur ta page de départ.

    Un exemple concert sur ton qui te démontrera que c'est une erreur de codage :
    • Lien : "Les SNH48 de Shanghai"
    • je clique et j'arrive sur une erreur 404
    • l'adresse affichée est : http://akb48-le-site.fr/snh48/snj48_Bienvenue_a_Shanghai.php, donc soit le fichier "snj48_Bienvenue_a_Shanghai.php" n'existe pas, soit le dossier "http://akb48-le-site.fr/snh48" n'existe pas
    • je fais afficher le contenu du dossier Index of /snh48/ (ce qui est possible dans ton cas)
    • et là je vois un fichier snh48_Bienvenue_a_Shanghai.php
    • je cliques dessus et oh miracle une page s'affiche !

    Donc au final erreur du serveur? Non!
    Erreur de lien : snj48_Bienvenue_a_Shanghai.php au lieu de snh48_Bienvenue_a_Shanghai.php



    Et effectivement tu as des lien qui pointent vers un dossier "wp" es-tu sur qu'ils sont corrects??

    Exemple : lien "AKB48 Les News du jour" on clique et on arrive sur l'adresse : http://akb48-le-site.fr/wp/akb48/

    Si je fais afficher que le contenu de "wp" je vois un wordpress.

    Donc es-tu certain qu'il y a un sous-dossier "akb48" dans ton dossier "wp"?
    Ou est-ce encore une fois une erreur de lien??



    Dans chacune de nos réponse on te donne des pistes mais c'est ton projet on ne va pas analyser chaque ligne de ton code (même si je l'ai fait pour ta page formulaire).

    Si on te dit ce qu'est une erreur 404 c'est pour que tu cherches dans cette direction, pour que tu comprennes ton erreur tout simplement.


    As-tu compris tes erreurs 404 finalement ou pas?
     
    Dernière édition: Avr 23, 2012
  6. sensei-kuma

    sensei-kuma Member

    Logique pour les news du jour seul le menu est créé, les wp pas encore donc tu n'as pas de lien pour aller quelque part
    (y a que akb48/wp essai qui est opérationnel)

    A force de refaire cent fois la même cjhose j'apprends donc les dossiers nogizaka46 et snh48 je suis allé dans public les créer moi même donc ils sont visibles, donc ils devraient se manifester

    Et quands à l'autre qui mets snh48/snj48 alors là je te mets au défi de trouver comment le h c'est transformer en j,
    je veux bien que je sois pas un enfant nait avec un ordi dans les mains mais quand même je fais attention.

    Quand au cms (sauf pour mettre des news journalière donc sous forme de blog) c'est niet parce qu'on peut pas en faire un site dynamique.............mais si j'y arriverai y a un an que j'ai commencé donc j'ai tout l'avenir devant moi on vit de plus en plus vieux.

    NB bien sur que je sais pas développer un site correctement je commence je suis loin de tout savoir.

    PS David une petite précision y'a pas de wp akb48 en essai il est juste répertorier sous akb48-le-site.fr/wp c'est un dossier d'essai mais j'ai pas de problème avec, c'est sur mon site que ca merde et dans wampserver ils existent les bougres
     
    Dernière édition: Avr 23, 2012
  7. pierre_kuhn

    pierre_kuhn New Member

    OK on va pas tourner pendant x temps dessus.
    Je regarde ce soir par ftp ce que je peux faire pour te recaler tous en place mais il me faut une promesse, tu transfert plus rien de ton pc vers le site.

    On peux faire de beau site dynamique en cms, faut juste vouloir ce mettre au boulot et pas copier coller du code à la bonne franquette.
     
  8. sensei-kuma

    sensei-kuma Member

    Stop j'ai trouvé , bon je fais mon mea culpa, donc j'ai eu beau chercher les liens sur le serveur et sur mes pages y'a un truc que j'ai oublié.........ce qui prouve que je sais pas tout c'est l'index et c'est dessus que ya les 2 erreurs .
    Bon je préparerais des chocolats
     
  9. pierre_kuhn

    pierre_kuhn New Member

    oh oui ta va pouvoir les préparés ;)
     
  10. David77

    David77 Member

    Alors perso je te trouve limite agressif dans tes messages alors que nous essayons de t'aider.

    Au final qui avait raison?

    Plutôt que d'être sur la défensive et agresser, regarde ce qu'on te dit, vérifie et ensuite on pourra avancer.

    Et concernant les CMS c'est justement fait pour avoir un site dynamique !

    Donc soit tu continues à coder en te documentant comme il faut sur le net (cours, forum dédié, etc...), soit tu passes sur un CMS.
    Et il n'y a rien de mal à en utiliser un, loin de là.

    Et quand tu dit :
    C'est toi qui tape le nom de fichier personne d'autre, et une erreur de frappe ça arrive à tout le monde (dans tes emails il y en a quelques unes par exemple) le tout c'est de vérifier un minimum avant d'accuser le serveur ou de dire que tout est bon...

    Allez je vais me prendre une tisane moi ça va me faire du bien :)
     
    Dernière édition: Avr 23, 2012
  11. sensei-kuma

    sensei-kuma Member

    Alors la bonne nouvelle c'est que du coup je viens de finir de réparer non seulement les liens mais les _style qui étaient mal fagoté.

    Alors merci d'avoir aidé le grognon maintenant je vais pouvoir continuer.....demain......et j'aurais des cms en complément promis. et j'essayerais d'être plus agréable.

    Bonne nuit à tous
     
    Dernière édition: Avr 23, 2012

Partager cette page