Configuration altérée suite à montée de version PHP 5.3.8 ?

npluyaud

New Member
#1
Bonjour.
Cet apres midi (mais cela remonte peut etre depuis 1 ou 2 jours), j'ai 2 erreurs (mais peut-etre d'autres cachés.
Cela provient peut-etre de l'evolution du moteur php en 5.3.8 (??)

la premiere concerne apparemment la configuration locale

Warning: phpinfo() [function.phpinfo]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /home/..../phpinfo.php on line 2
La seconde, extremement genant, concerne des extensions comme PDO (log issue du fichier error)

[08-Dec-2011 19:11:58] PHP Warning: PHP Startup: eAccelerator: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0
[08-Dec-2011 19:11:58] PHP Warning: PHP Startup: PDO: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0
[08-Dec-2011 19:11:58] PHP Warning: PHP Startup: pdo_sqlite: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0
J'ai bien ouvert un ticket, mais pas de réponse... j'essaie la communauté, en esperant qu'elle soit plus ... réactive. :(
 
Dernière édition:

pierre_kuhn

New Member
#2
Bonsoir

Est ce que tu as fais la monter de version ou bien c'est ph qui te là fait ? si c'est toi, essaye un retour en arrière pour voir.
Sinon est ce que ton cms est à jour ?
 

npluyaud

New Member
#3
Comme je n'ai rien fait, c'est donc ph....

Mon CMS ? c'est d'un côté Piwigo pour ma galerie photo perso, et un site fait par mes soins....
J'ai un peu la rage en fait.
D'après ce que je comprends, les extensions ne sont pas compatibles avec la version compilée de PHP.
Or je n'ai pas accès à ces extensions....
 

pierre_kuhn

New Member
#4
Pas accès aux extensions, c'est quoi ce binz, tu as bien monter le site et donc les extensions non ?
 

npluyaud

New Member
#5
Et bien non, sur le mutualisé, on n'a pas accès aux .so .... je dis une connerie ?

En tout cas, depuis 2 ans que je suis chez ph, je n'ai jamais touché à ça !

Regarde mes logs, on voit bien une incompatibilité entre le moteur et les extensions
Module compiled with module API=20060613
PHP compiled with module API=20090626
 

npluyaud

New Member
#7
Merci à toi. :)

Mais pour ma culture personnelle, j'aimerais quand même savoir le pourquoi du comment.
Si sur un mutualisé on ne gère pas les extensions (en terme de fichiers hein, pas en terme d'activation qu'on peut maîtrisé via un php.ini perso), je ne comprends pas comment cela est arrivé.
Par contre, si on gère, alors je ne comprends pas non plus pourquoi pdo fonctionne normalement depuis le début de mon hébergement..

Et puis il y a aussi ce problème de "timezone setting"... Qu'on ne me dise pas qu'on est capable de maitriser cette information sur un mutualisé..

Warning: phpinfo() [function.phpinfo]: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CET/1.0/no DST' instead in /home/pluyaudn/public_html/nicolas/phpinfo.php on line 2
 

PH-Saber

Administrator
Membre du personnel
#8
Bonjour,

Merci pour votre retour, est-ce que votre script est compatible avec php 5.3 ? Si la réponse est non, nous pourrions vous déplacer sur un serveur utilisant une version php moins récente si vous voulez ?

Bonne journée à vous,
 

npluyaud

New Member
#9
Vu les messages d'erreur, je ne crois pas qu'un php moins recent y ferait grand chose.
ce sont les versions qui ne sont pas en phases, enfin de ce que je peux en déduire d'apres les logs.

meme un phpinfo() renvoie une erreur ! (voir le chapitre Date)
phpinfo()
et l'extension PDO n'est pas activée ...

Quand vous avez migré PHP, vous avez aussi migré les extensions... (je sais, question conne, mais il fallait que je la pose :) )
 
Haut