Comment choisir sa version de PHP ?

#1
Bonjour,

J'ai bien noté que vous alliez migrer de 5.3 à 5.4 prochainement.
J'ai deux questions.
- Y a-t-il un moyen de tester un site pour vérifier qu'il supporte bien php 5.4 autrement qu'en le migrant ?
- Vous dites dans votre message "La plateforme Hybride vous offre la possibilité de choisir entre plusieurs versions PHP (5.2, 5.3, 5.4, 5.5)". Comment faire ?

Merci d'avance.
 
#2
Bonjour,

Pour essayer de répondre à vos questions, vous pouvez essayer votre site en local avec des logiciels comme UwAmp qui vous permettent d'installer la version PHP de votre choix en local et de switcher entre chaque version installée.

Pour changer votre version de PHP sur votre serveur, l'option est disponible sur le cPanel : "Sélectionner une version de PHP"
 
#3
Merci pour votre réponse rapide.

Ok pour installer une version en local mais je pensais plutôt à un script qui scannerait les fonctions pour déceler les incompatibilités directement chez vous. Cela n'existe peut-être pas.

Pour la seconde question, j'ai bien regardé l'option "Selctionner une version de php" de cPanel mais j'obtiens le message dont j'ai fait une capture ici :

erreurph.jpg

Ce message disparaît au bout de quelques secondes. C'est peut-être du au fait que la seule version disponible pour l'instant est la 5.3 ?

Pour info je suis en Hybrid Multi sur Uteda.
 
#4
Je ne sais pas si ce genre de script existe (j'ai vraiment un doute), si vous utiliez un CMS il faut voir dans la config requise si c'est pris en compte.

Pour votre autre question je ne saurai dire car je ne travaille pas chez PH, e suis un utilisateur comme vous ;)
 
#5
Je ne sais pas si ce genre de script existe (j'ai vraiment un doute), si vous utiliez un CMS il faut voir dans la config requise si c'est pris en compte.

Pour votre autre question je ne saurai dire car je ne travaille pas chez PH, e suis un utilisateur comme vous ;)

Merci pour votre aide. je vais voir ce que répondra PH pour le choix de la version de php.
Pour la question du script de test, je suis assez d'accord sur le peu de chance que ça existe. En tout cas je n'en ai jamais vu..
 

pierre_kuhn

New Member
#6
Bonsoir

Pour la version de php, il faut se trouver sur les dernier serveurs que nous avons mis en ligne. IL ne me semble pas que uteda ai cela.

Si le cms est encore maintenu, il est logiquement compatible php 5.4. De quel cms il s'agit ?
 
#7
Bonsoir,

Ce n'est pas un CMS, un annuaire (Arfooo) qui n'est plus maintenu. Je sais qu'il ne passe pas php 5.5 mais j'ignore pour 5.4. C'est pour cela que le fait de pouvoir revenir à une 5.3 en cas d'incompatibilité est importante pour moi.

Cordialement.
 
Haut