Certificat SSL - Let's Encrypt - PlanetHoster

Discussion dans 'Certificat SSL' démarrée par PH-Mina, Déc 7, 2015.

  1. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Support communautaire pour la mise en place de let's Encrypt. N'hésitez pas à poser vos questions.

    English version : https://forums.planethoster.com/threads/exclusive-free-ssl-to-all-our-customers.4731/

     
    Dernière édition par un modérateur: Oct 24, 2017
  2. thebachman

    thebachman New Member

    Cool, projet prometteur que j'attends avec impatience!! :)
    Par contre toujours pas d'icône chez moi dans cPanel!! :p
     
  3. daf

    daf Member

    Pas encore d'icône chez moi non plus. En tout cas, merci à PlanetHoster de proposer cette option très utile.
     
  4. Calitel

    Calitel New Member

    Je pense avoir fait une bourde.
    Car pas d'icône chez moi non plus, et je viens d'écrire au support avant d'avoir lu ce forum.
    Je ne suis donc pas un cas isolé...
     
  5. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Bonjour à tous,

    Le processus de déploiement est en cours. L'icône sera graduellement accessible au cours des prochaines heures.

    Merci pour votre confiance.
     
  6. vikduf

    vikduf New Member

    Bonjour!
    Le PHSSL est activé sur mon Cpanel (merci beaucoup)

    Je peux sans problème activer le SSL pour mes sous-domaines, par contre, quand j'essaie de l'activer pour un domaine compagnon cela ne marche pas.

    Quelqu'un a le même problème?
     
  7. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Vikduf,

    Il faut bien comprendre que l'installation ne fonctionne que si votre domaine pointe bien vers le serveur en direct, si vous utilisez une service comme CloudFlare cela ne fonctionne malheureusement pas.

    Pouvez-vous SVP me fournir le nom de domaine en MP afin que je puisse regarder à cela ?
     
  8. vikduf

    vikduf New Member

    Bonjour!

    Oui j'en suis conscient et le domain pointe bien sur mon serveur.
    Je vous ai envoyé le nom de domaine par mp

    Merci beaucoup en tout cas pour cette fonctionalité et pour l'aide!
     
  9. ClientPH

    ClientPH New Member

    Bonjour,
    Mon serveur est : gorgun ... Pas de service de SSL gratuit ?
    C'est pour quand ?

    Merci,
     
  10. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Bonjour,

    Le déploiement est progressif. Cela sera disponible sous peu.
     
  11. ClientPH

    ClientPH New Member

    •Merci Mina, toujours Top service, Merci...
    Bonne journée,
     
  12. thebachman

    thebachman New Member

    Bonjour,

    J'ai un doute, les mutualisés auront droit aussi à Let's Encrypt n'est-ce pas?

    Comme je sais que beaucoup ont déjà l'icône sur leur cPanel, je ne l'ai pas encore, d'où ma question.
     
  13. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Bonjour,

    Oui tous les hébergements mutualisés posséderont le certificat PHSSL gratuit (validé par Let's Encrypt). L'option sera accessible via le cPanel.

    Pour un usage professionnel, nous recommandons les certificats SSL possédant une assurance (10 000 $ ou plus) par l'émetteur en cas de faille de sécurité. Pour les sites web e-commerce, un certificat SSL avec validation certifiée (SSL EV) permet d'obtenir la confiance du visiteur. Pour plus d'information, vous pouvez consulter nos offres ou prendre contact avec notre service pré-vente :

    https://www.planethoster.com/fr/Certificats-SSL

    Pré-vente : pre-ventes@support.planethoster.info
     
  14. ClientPH

    ClientPH New Member

    Bonjour,
    C'est pour quand le certificat ssl gratis sur le serveur Gorgun ?
    Plan : Hybride Illimité

    Merci d'avance,

    ClientPH
     
  15. thebachman

    thebachman New Member

    Le déploiement commence!
     
  16. thebachman

    thebachman New Member

    J'ai le certificat Let's encrypt!! Super!!
    En revanche, pourquoi j'ai le cadenas vert sur la page d'administration de mon WordPress, alors que sur mon site j'ai bien la page https://*** mais sans cadenas?
     
  17. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Bonjour,

    Svp, Ouvrer un nouveau post sur la section Certificat SSL du forum en nous transmettant plus d'information. Nous pourrons mieux vous aider.
     
  18. Winroc

    Winroc New Member

    Bonjour,

    Tous les jours je me connecte avec l'espoir de voir "l'icône"... mais non, elle n'apparait pas :(

    J'espère que ce n'est pas un déploiement par ordre alphabétique... aujourd'hui gorgun... mon serveur est uteda:(

    Enfin je vais prendre mon mal en patience, mais j'avais besoin de m'exprimer ;)
     
  19. PH-Jay

    PH-Jay Member

    L'installation sera faite sur votre serveur d'ici les prochaines heures !
     
  20. Winroc

    Winroc New Member

    Parfait merci. Nickel :)

    j'ai pu mettre en place et cela fonctionne très bien.
    J'ai un maintenant un problème mineur de redirection de domaine non bloquant (mais j'ai ouvert une demande de support).
     
  21. PH-Mina

    PH-Mina Administrator Membre de l'équipe

    Nous vous invitons à ouvrir un nouveau sujet dans la section certificat SSL du forum. La solution que nous vous fournirons aidera d'autres personnes dans la même situation que vous.
     
  22. cracrayol

    cracrayol New Member

    Bonjour.

    J'ai déjà un certificat SSL Let's Encrypt mis en place manuellement sur certains de mes domaines/sous-domaines (j'ai participé à la bêta fermée). Est-ce que PH prend en charge automatiquement le renouvellement de ceux-ci ou il y a des opérations à faire ?

    Car dans la partie PHSSLFree, certains de ces domaines sont maintenant avec le bouton "Activation" en vert, sans avoir forcement demandé l'activation.

    D'ailleurs, en désinstallant le certificat sur un de ces sous domaines (mais en conservant quand même le certificat), le bouton d'activation de la page PHSSLFree restait vert. Normal ?
     
  23. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Cracrayol,

    Je vous confirme que notre système tentera automatiquement de renouveler les certificats Let's Encrypt 5 jours avant leur expiration. (Ceux-ci doivent être resignés au 90jours)

    Concernant les boutons dans les cPanel, nous sommes actuellement sous une version Beta et nous devrions déployer une version plus avancée au niveau UX corrigeant ces aléas visuels.

    Si vous avez d'autres questions/remarques nous restons bien évidement à votre disposition via ce forum.

    Cordialement.
     
  24. daf

    daf Member

    Bonjour,
    Merci à PlanetHoster pour cet excellent support de Let's Encrypt. Je viens d'essayer et je suis très impressionné par le côté “presse-bouton” dans cPanel : un seul clic et ça roule ! Magnifique !

    Si je comprends bien, il y a au moins une opération à faire “manuellement” après le clic magique : mettre en place une redirection générale de toutes les pages de http://www.nom-de-domaine.com vers https://www.nom-de-domaine.com, pour bien assurer la sécurité des visiteurs. C'est bien ça ?

    Quelqu'un voit-il d'autres opérations “manuelles” utiles, à effectuer après obtention du certificat Let's Encrypt ?
     
  25. photolit

    photolit New Member

  26. photolit

    photolit New Member

    Voici la réponse fournie par le SUPPORT :

    Code:
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^VotreDomaine\.com [NC]
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI}
    Ça fonctionne très bien. Merci
     
    Dernière édition par un modérateur: Déc 29, 2015
  27. Seanthi

    Seanthi New Member

    Bonjour et Félicitation pour le support de let's Encrypt. Ca me confirme chaque jour d'avantage que je ne me suis pas trompé en vous choisissant .
    Si le support de let's Encrypt est disponible pour les offres d’hébergement mutualisés hybride et revendeur, y a -t-il une possibilité pour ceux qui sont sur VPS? Peut-on en bénéficier aussi ou pas? sinon comment faire?
    Merci et encore Bravo pour l'initiative.
     
  28. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Seanthi,

    Nous vous remercions pour ce beau message, cela nous fait fort plaisir et sachez que nous faisons le maximum pour vous en offrir plus.

    Actuellement le module peut-être installé sur les serveurs VPS ou dédié (à quelques conditions), sachez cependant que Let'sEncrypt est encore en Beta, nous ne pouvons donc pas vous assurer un fonctionnement 100% stable (sans bugs). Je vous invite à contacter le support technique pour avoir toutes les modalités concernant l'installation.

    Sachez cependant qu'une fois que celui-ci stable (prochains mois), nous procéderons à un déploiement massif et gratuit sur nos infrastructures et cela sera totalement supporté par nos techniciens.

    Bien à vous.
     
  29. Seanthi

    Seanthi New Member

    C'est super comme nouvelle. So let's enjoy let's Encrypt et vive PlanetHoster...
     
  30. Dave

    Dave New Member

    Bonjour,

    C'est la première fois que j'utilise un certificat SSL. J'ai cliqué sur le bouton d'activation dans mon CPanel, mais maintenant je ne sais pas ce que j'ai à faire d'autre. Quelqu'un peut m'éclairer?

    Merci!
     
  31. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    Bonjour,

    L'installation du certificat peut prendre plusieurs minutes. (Environ 10 min.)

    Par la suite vous pourrez tester l'installation avec le site suivant -> https://www.ssllabs.com/ssltest/

    Une fois l'installation terminée, vous devrez rediriger le trafic http vers https, vous trouverez comment faire--> ici <--
     
    Dave aime votre message.
  32. grunjo

    grunjo New Member

  33. grunjo

    grunjo New Member

    Vous utilisez un CMS du style wordpress ou prestashop ? Il y a plein de tuto sur le net pour sa mise en place :)
     
  34. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    Bonjour @grunjo ,

    L'avertissement ne semble plus présent sur votre site. Toutefois, la plupart du temps, le problème provient du fait que vous aviez des sources non sécurisées sur le site.

    Vous pouvez vérifier quelles sont ces sources à l'aide du site suivant --> https://www.whynopadlock.com/index.html

    Il vous suffira de changer l'appel des liens http vers https.

    Bonne journée!
     
    Dernière édition: Jan 11, 2016
  35. photolit

    photolit New Member

    Bonjour,
    J'ai installé Let's encrypt qui fonctionne correctement sans les WWW mais pas avec les WWW. Par exemple : www.semaphoreandco.com la redirection ne fonctionne pas. le cadenas est absent. Je n'ai pas trouvé dans la base le code adéquat.
    Merci pour votre aide et surtout pour votre participation active à la protection des données.
     
  36. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    LetsEncrypt est installé sur le www. Vous pouvez le constater en joignant le site directement via https.
    ( https://www.semaphoreandco.com )

    Vous trouverez un petit tutoriel comment rediriger le http vers https--> ici <--
     
  37. photolit

    photolit New Member

    Bonjour et merci,
    J'avais déjà consulté ce tutoriel.
    Je viens d'essayer et ça ne fonctionne pas. Bien sûr j'ai vidé le cache.
    Tapez simplement : (http://www.semaphoreandco.com) Si je mets le https ça fonctionne oui, mais tous les internautes ne le savent pas.
    Merci
     
  38. David77

    David77 Member

    Et avec ce code, trouvé ici : https://forums.planethoster.com/thr...rdpress-mais-pas-sur-le-site.4712/#post-17849

    Code:
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^Votre-Domaine.fr$
    # Redirection vers WWW mais en HTTPS
    RewriteRule ^(.*)$ "https\:\/\/www\.Votre\-Donaine\.fr\/$1" [R=301,L]
    
    # Redirige tout contenu HTTP à HTTPS
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ "https\:\/\/www\.Votre\-Donaine\.fr\/$1" [R=301,L]
     
  39. kspal

    kspal New Member

    bonjour,

    Tout d'abord merci de nous faire bénéficier des certificats gratuits Let's encrypt !

    j'ai activé sans problème le PH SSL Free sur 2 de mes domaines
    mais l'activation n' a plus de l'air de fonctionner pour les 3autres domaines pour lesquels j'ai demandé l'activation depuis 1 semaine , il y a toujours le statut "en cours...".


    Y a t il un probleme sur l'activation ?

    Cordialement
    Pascal
     
  40. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Pascal,

    Pouvez-vous SVP me donner les deux noms de domaines afin que je puisse être en mesure de regarder pourquoi l'activation ne s’est pas encore effectuée ?

    Si vous ne souhaitez pas communiquer ceux-ci en public, vous pouvez me contacter via ce forum en message privé.

    Merci à vous et un excellent weekend.
     
  41. kspal

    kspal New Member

    bien sur voici le noms de domaine "bloqués" en cours d'activation :
    - menurepas
    - bohban.com

    merci d'avance !
     
  42. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

  43. Dave

    Dave New Member

    Merci! ça fonctionne.
     
  44. kspal

    kspal New Member

  45. Dave

    Dave New Member

    Bonjour, j'ai activé le SSL sur trois de mes domaines et ça ne fonctionne pas pour l'un d'entre eux. Quand je modifie mon fichier .htaccess, le site ne fonctionne plus. Pouvez-vous m'aider?

    Le domaine en problème est : monpetitbonheuramoi.ca

    Merci!
     
  46. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    Bonjour,

    Le problème est maintenant corrigé. Le soucis provient du .htaccess à la racine qui créé une redirection. Donc pour letsEncrypt, le domaine était inaccessible.

    L'installation est maintenant bien terminée.
     
  47. Dave

    Dave New Member

    Merci, ça fonctionne.

    J'ai un autre souci. Avec ce domaine, j'ai un sous domaine que j'aimerais aussi encrypter. Est-ce qu'on peut m'aider?

    Le sous domaine est communication.monpetitbonheuramoi.ca

    Merci!
     
  48. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Dave,

    Je pense que la demande de signature à été validé sur un ticket, pouvez-vous me valider que c'est correcte maintenant?

    Bien à vous.
     
  49. Dave

    Dave New Member

    Ce n'est pas fonctionnel. La redirection ne se fait pas
     
    Dernière édition: Jan 20, 2016
  50. Dave

    Dave New Member

    Finalement, j'ai trouvé et tout est fonctionnel.

    Merci!
     
  51. Carlton2001

    Carlton2001 New Member

    Bonjour,

    Bloqué "en cours" depuis ce matin :)
    -> carlton2001.com
     
  52. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    Le problème est corrigé. L'installation du certificat devrait maintenant fonctionner.
     
  53. Carlton2001

    Carlton2001 New Member

    Bonjour,

    Merci pour le retour mais.
    Tous mes boutons d'activation sont revenus à l'état "Activation" et n'ont plus aucun effets lorsque j'essaye de les activer, que ce soit avec Chrome, Edge ou Firefox.
     
  54. PH-Marcandre

    PH-Marcandre New Member Membre de l'équipe

    Pouvez vous ouvrir un ticket sur le support s.v.p. --> https://my.planethoster.net/my-supports

    Nous regarderons à corriger le problème.

    Merci
     
  55. djmorphe

    djmorphe New Member

    Bonjour,
    Tous mes domaines sont notifiés actifs dans PH SSL Free sur mon cPanel, mais dès que je tente d'activer le SSL (Joomla, Prestshop) ou de modifier directement le .htaccess j'ai ce type de message d'erreur :

    404 Not Found
    The server can not find the requested page:

    www.mondomaine.fr/cp_errordocument.shtml (port 443)

    Une idée de solution ????
     
  56. Listeur

    Listeur New Member

    Bonjour,

    J'ai voulu activer l'option PH SLL Free sur mon domaine, mais il s'est mis en erreur. J'ai supposé, après avoir lu ce thread, que c'était à cause de mon htaccess que j'ai modifié. Mais je n'ai aucun moyen de faire revenir le bouton "Activation".
    J'ai activé l'option pour un de mes sous domaine, pour tester, avec grand succès.

    Comment faut-il faire pour récupérer le bouton "activation" ?
     
  57. netpresence

    netpresence Member

    Bonjour,

    J'ai essayé la fonctionnalité sur deux sites (2 comptes cpanel différents, serveur hari). Les deux m'indiquent "erreur"
     
  58. Comtugal

    Comtugal New Member

    Depuis quelques jour, pareil pour moi, impossible d'activer un domaine avec let's encrypt. Ceux deja en route fonctionnent correctement.
     
  59. JoséM

    JoséM New Member

    Salut à tous,

    J'ai récemment changé mon nom de domaine principal.
    PH SSL free est toujours affiché comme étant Actif, mais le certificat fait référence à mon ancien nom de domaine principal...
    Je ne trouve pas non plus .htaccess
    Pourriez-vous m'aider?

    Le domaine en problème est: arthology.org
    Merci!
     
  60. POX

    POX New Member

    Bonjour,

    Je viens de découvrir que Planethoster propose des certificats SSL gratuits avec Let's Encrypt.
    J'ai essayé d'en activer sur 2 de mes domaines (iampox.com et diktart.com) mais j'ai eu une erreur pour chacun des deux.
    Le domaine diktart.com renvoie à un site qui fonctionne avec Bigcartel (CMS e-commerce) donc je pense que cela doit venir de là.
    Par contre, pour le domain iampox.com, c'est mon site perso et tout est hébergé sur mon plan mutualisé Planethoster donc je ne vois pas d'où peut venir le problème.
    Si quelqu'un pouvait m'indiquer pourquoi j'ai eu ces erreurs pour mes deux domaines, cela serait vraiment apprécié.

    Merci !
     
  61. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour à tous,

    Pouvez-vous SVP rentrer en contact avec moi en MP et me fournir votre domaine afin que je puisse regarder ce qu'il se passe mal si le statut de votre demande LetsEncrypt est actuellement en erreur ?

    Cordialement,
    Quentin
     
  62. pjmh53

    pjmh53 New Member

    Bonjour.

    J'ai activé (ou tenté d’activer) les certificat PHP SSL. Tout c'est bien déroulé en 1 clic pour le sous-domaine sabre.galerie-angelique.fr et pour le domaine associé lise-poirier.fr. Par contre le domaine galerie-angelique.fr et le sous-domaine piwik galeie-angelique.fr se sont mis en erreur. Je suis pourtant sûr d'avoir fait la même manœuvre (limitée à 1 clic!).

    Merci par avance.
     
  63. owenders

    owenders New Member

    Bonjour,

    N'y connaissant pas grand chose en certificat et SSL/TLS, j'ai quelques questions par rapport à cet article sur un blog de planethoster:
    http://blog.avis-planethoster.com/information/installation-certificat-ssl-https-cpanel-956

    1) Est-ce que le certificat Let's Encrypt gratuit est un certificat auto-signé comme il est fait mention dans l'article référencé ci-dessus ? Si oui, cela veut-il dire que le visiteur devra confirmer avant d'accéder au site en https ?

    2) Dans l'article, il est mentionné qu'il faut être hébergé sur une IP dédiée. Pourquoi le certificat Let's Encrypt est-il alors aussi valable sur un hébergement mutualisé?

    3)Pour éviter d'avoir un duplicate content entre http et https, et ne souhaitant pas que les visiteurs soient redirigés vers le site https (et évitent ainsi d'avoir des messages de confirmation de sécurité -> voir ma question 1), j'ai supprimé tous les certificats Let's encrypt. Est-il possible de les ravoir si un jour je décide de les utiliser?

    Merci d'avance.
     
  64. cdsweb

    cdsweb New Member

    Bonjour,

    J'ai un soucis avec l'activation du sslfree sur au moins un de mes sous-domaine. J'ai demandé son activation hier soir et il est toujours marqué " en cours"

    J'avais déjà eu ce soucis samedi sur le domaine principale qui avait été résolu assez rapidement par le service technique.

    Cordialement,
     
  65. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour CDsWeb,

    Pourriez-vous SVP me communiquer le domaine afin que je puisse regarder cela personnellement ?

    Merci d'avance.
     
  66. Comtugal

    Comtugal New Member

    Bonjour, petit problème avec erreur pour le domaine que je vous ai envoyé par mail Quentin. Merci
     
  67. RomRom92

    RomRom92 New Member

    Bonjour,
    J'ai activé le LetsEncrypt depuis mon cPanel (onglet PHSSLfree) il y a 2 jours, et l'état demeure en Erreur. Que se passe t-il ?
    Nom de domaine concerné : furycom.fr

    Je vous remercie par avance pour votre aide.
     
  68. HasClass0

    HasClass0 New Member

    Bonjour,
    il semble que j'ai le même problème que CDsWeb.
    Activation du certificat demandée hier soir et toujours indiqué "En cours".

    [Edit 05/04/16] Certificat en place. si qq'un est intervenu, merci.

    Cordialement.
     
    Dernière édition: Avr 5, 2016
  69. Seanthi

    Seanthi New Member

    Bonjour,
    j'ai changé recensement le nom de mon serveur VPS et je constate que le site en HTTPS affiche un message d'avertissement rouge à faire fuir les visiteurs. Quand je vérifie le contenue du message d'erreur, il me fait remarqué que mon certificat est adressé à un autre serveur en me mettant l'ancien nom de serveur, ce que je comprend bien. Ma question est de savoir comment corriger le tir?
    Merci.
    Raoul
     
  70. pjmh53

    pjmh53 New Member

    Certificat en erreur pour mon domaine galerie-angelique.fr et le sous domaine piwik.galerie-angelique.fr, alors que le domaine associé lise-poirier.fr est passé comme une lettre à la poste.
    IntoDNS donne la même page pour le domaine et le domaine associé, et une page blanche pour le sous-domaine.
    Why No PadLock (https://www.whynopadlock.com/check.php) donne le résultat
    "SSL verification issue (Possibly mis-matched URL or bad intermediate cert.). Details:
    ERROR: no certificate subject alternative name matches" ​
    avec une croix rouge évocatrice d'erreur, et
    "Certificate valid through: Aug 27 06:02:32 2016 GMT
    Certificate Issuer: GeoTrust Inc.
    SSL Protocols Supported: TLSv1 TLSv1.1 TLSv1.2" ​
    avec une coche verte pour le domaine comme pour le sous-domaine.
    J'en déduis, sans être certain de mon raisonnement, qu'il existe un certificat mais que ce n'est pas le bon. Mais dans mon cPanel je ne vois qu'un seul certificat SSL, lié au domaine associé (qui fonctionne en https, ce qui est logique). Où se cache le certificat que trouve Why No PadLock qui semble être la cause de l'erreur?
    Quelqu'un peut-il m'aider?
    Merci.
     
  71. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Pjmh53,

    Pouvez-vous me valider que votre demande de signature Let'sEncrypt fonctionne maintenant correctement ?

    [​IMG]

    Bien à vous.
    Quentin
     
  72. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour RomRaom92,

    Le problème pour votre demande vient du fait que LetsEncrypt n'arrive pas à valider votre demande !

    Code:
    IMPORTANT NOTES:
    - The following errors were reported by the server:
    
      Domain: furycom.fr
      Type:  unauthorized
      Detail: Invalid response from http://furycom.fr/.well-known/acme-
      challenge/3OSimmNwdIaQ_EUoj7HlOoJDHq15fc0aQ3Sl-zFP5uM
      [85.236.153.18]: 404
    
      Domain: www.furycom.fr
      Type:  unauthorized
      Detail: Invalid response from http://www.furycom.fr/.well-known
      /acme-challenge/At9ohBaWf21ojSi8tn8Dku1H40S09qbHsbAsqVrFdn4
      [85.236.153.18]: 404
    
      To fix these errors, please make sure that your domain name was
      entered correctly and the DNS A record(s) for that domain
      contain(s) the right IP address.
    Cela vient très probablement du fait que vous avez une règle dans votre fichier .htaccess qui bloque cela.

    Pouvez-vous SVP ajouter ce bloc de code dans votre fichier .htaccess et me revenir une fois cela effectué?

    Code:
    RewriteCond %{SCRIPT_FILENAME} -d [OR]
    RewriteCond %{SCRIPT_FILENAME} -f
    RewriteRule "(^|/)\." - [F]
    Merci d'avance.
     
  73. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Owenders,

    ---> Cet article est à vrai dire très ancien (2011) et de l’eau a coulé sous les ponts depuis !

    ---> Les certificats SSL de Let's Encrypt sont signé par cette autorité qui est reconnu par la majorité des navigateurs récents! Il n'y aura donc aucune validation/confirmation à effectuer manuellement lors de l'accès sur le site en HTTPS !

    ----> Depuis 2011, les adresses IPv4 sont arrivé à saturation au niveau de nos fournisseurs (RIPE et ARIN). Nous avons donc implémenté des systèmes comme SNI qui permet d'installer plusieurs certificats SSL sur l'IP partagée du serveur ! Il ne faut donc plus avoir d'adresse IP dédiée pour un site voulant bénéficier d'un certificat SSL à ce jour.

    ----> Pour cela je vous invite à faire une règle dans votre fichier .htaccess afin d'éviter le contenu dupliqué, vous trouverez plus d'information à ce sujet ici: https://my.planethoster.net/knowledgebase/article/87/forcer-le-ssl-sur-un-nom-de-domaine

    Bien à vous.
     
  74. RomRom92

    RomRom92 New Member


    Bonjour Quentin,

    Je vous confirme l'ajout du bloc de code dans le fichier .htaccess

    Merci beaucoup
     
  75. pjmh53

    pjmh53 New Member

    Cela fonctionne pour le domaine associé lise-poirier.fr. Mais cela fonctionnait déjà pour ce domaine. Par contre le domaine galerie-angelique.fr et le sous domaine piwik.galerie-angelique.fr sont toujours en erreur.
     
  76. pjmh53

    pjmh53 New Member

    Toujours personne pour m'aider ?
    J'ai essayé empiriquement la solution proposée à RomRaom92, sans succès.
    Merci d'avance si quelqu'un peut me dépanner.
     
  77. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour PJMH53,

    Je viens de trouver votre problème, pour preuve cela cela fonctionne sur le sous domaine piwik:

    upload_2016-4-14_11-45-43.png


    Dans votre cas votre sous-domaine se trouve dans le dossier suivant:

    Le problème vient du fait que le fichier .htaccess du dossier parent (Drupal) est lui au pris en compte et c'est celui-ci qui bloque LetsEncrypt:

    J'ai donc temporairement renommé le fichier /home/ynjolwck/public_html/.htaccess afin de pouvoir faire la requêtes pour le sous domaine piwik !

    Je vous recommande donc de changer le répertoire/chemin de vos sous-domaine/domaines supplémentaires en dehors du public_html pour que vous n'aillez pas ce genre de problème.

    upload_2016-4-14_11-49-27.png

    Bien à vous.
     
  78. pjmh53

    pjmh53 New Member

    Un grand merci. Cela fonctionne bien.
    Reste à savoir pourquoi le .htaccess de Drupal introduit une erreur et comment la corriger. Mais cela fonctionne en mettant les sous-domaines dans un autre répertoire et c'est le principal.
    Encore merci.
     
  79. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

  80. Chris3872

    Chris3872 New Member

  81. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Chris,

    Je vous confirme que le demande a maintenant été traitée avec succès !

    Code:
    The SSL certificate is now installed onto the domain “creation-site-internet-grenoble.fr” using the IP address “85.236.157.21”. Apache is restarting in the background.
    Vous pouvez vérifier le bon fonctionnement ici: https://www.sslshopper.com/ssl-checker.html#hostname=creation-site-internet-grenoble.fr
     
  82. RomRom92

    RomRom92 New Member

    Bonjour Quentin,
    Le statut demeure en "Erreur" pour le domaine furycom.fr, malgré l'ajout du bout de code dans le .htaccess. Que se passe t-il ?
    Je vous remercie
     
  83. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour RomRom92,

    Malgré l'ajout du code dans votre fichier .htaccess la validation au niveau de Let'Encrypt n'a pas abouti;
    Code:
    IMPORTANT NOTES:
    - The following errors were reported by the server:
    
       Domain: furycom.fr
       Type:   unauthorized
       Detail: Invalid response from http://furycom.fr/.well-known/acme-
       challenge/hi7xLxBe0h65mtEsZqPElabx1Yb7zlh0Bj3FGTMOnlI
       [85.236.153.18]: 403
    
       Domain: www.furycom.fr
       Type:   unauthorized
       Detail: Invalid response from http://www.furycom.fr/.well-known
       /acme-challenge/jCq5Q_9QTjgIpCer7IM7KUodU9V0xaiueGFkHRNXLz8
       [85.236.153.18]: 403
    
       To fix these errors, please make sure that your domain name was
       entered correctly and the DNS A record(s) for that domain
       contain(s) the right IP address.
    
    -----------
    

    J'ai temporairement renommé votre fichier .htaccess afin de pouvoir faire la demande correctement.

    Après vérification, il semble y avoir une issue d'ouverte au niveau de CakePHP afin que la validation sur "/.well-known/acme-challange/" soit possible (https://github.com/cakephp/app/issues/368) Le correctif serait de rajouter ceci dans le fichier .htaccess:

    Code:
    RewriteRule ^(\.well-known/.*)$ $1 [L]
    Je vous invite à rajouter cela afin que le renouvellement dans 90 jours se passe correctement.

    Bonne journée!
     
  84. RomRom92

    RomRom92 New Member

    Merci pour votre réactivité ! Cela fonctionne bien.
    Je viens de rajouter le bout de code dans mon fichier .htaccess afin d'éviter des problèmes pour le renouvellement.

    Bonne journée
     
    Dernière édition: Avr 20, 2016
  85. daf

    daf Member

    Bonjour,
    Sur l'interface PH SSL Free Tools, comment désactiver la protection par SSL d'un domaine ?
    Si ce n'est pas automatisé, comment le faire manuellement ?
    Merci pour toute aide.
     
  86. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Daf,

    Pour cela vous pouvez allez dans le cPanel >> SSL/TLS et supprimer la clé privée lié à votre domaine.

    Noté, qu'il ne sera malheureusement pas possible de réactiver de LetsEncrypt par la suite en cas de suppression.

    Bien à vous.
     
  87. daf

    daf Member

    Merci pour votre réponse rapide.

    Autre question : en cas de problème de renouvellement automatique du certificat (à cause d'un .htaccess mal configuré, par exemple), à quelle fréquence le système réessaie-t-il de renouveler le certificat (c'est-à-dire d'accéder au répertoire /.well-known/acme-challenge/, etc.) ?
     
  88. Sansa

    Sansa New Member

    Bonjour,

    Je viens d'activer mon SSL gratuit let's encrypt. Le processus a été validé, mais mon site apparaît toujours la même adresse en http et non en https.

    Y-a-t-il une démarche supplémentaire à faire après l'activation dans le Cpanel?

    D'avance merci pour votre aide.
     
  89. ClientPH

    ClientPH New Member


    Bonjour, vous pouvez placer ce code dans le fichier .htaccess
    Ce code vas forcer votre site vers https

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

    RewriteEngine On
    RewriteCond %{HTTPS} !=on
    RewriteRule (.*) https://www.votresite\.com/$1 [R]
     
  90. revesdepaysages

    revesdepaysages New Member

    Bonjour, j'essaye sans succes d'activer PH SSL free sur mon domaine principal (www.revesdepaysages.fr) et sur mon multi domaine (www.polytesolet.com) . Je reste en statu "erreur".
    Il semblerait que les htaccess bloque la manoeuvre?
    Pourriez vous me donner une piste?
    merci
    cordialement.
     
    Dernière édition: Jui 9, 2016
  91. PH-Quentin

    PH-Quentin Administrator Membre de l'équipe

    Bonjour Reves de Paysages,

    Je pense que votre problème à été corrigé car à ce jour les deux domaines sont signés avec LetsEncrypt;

    Bien à vous.
     

    Pièces jointes:

  92. Anrolosia

    Anrolosia New Member

    Bonjour,

    j'ai un soucis sur l'activation via PH SSL Free Tools sur un sous domaine à usage privé, le statut est en erreur.

    Possible de recevoir de l'aide ou au moins être contacté en mp pour que j'ai la raison de l'erreur ?

    Cordialement,
     
    Dernière édition: Jui 15, 2016
  93. LaurentD

    LaurentD New Member

    Bonjour,

    j'avais un message d'alerte m'indiquant connexion non sécurisée et que mon certificat était expiré, j'en ai recréé et installé un autre et depuis j'ai ce message: Les propriétaires ont mal configuré leur site web. Pour éviter que vos données ne soient dérobées, Firefox ne s’est pas connecté à ce site web.

    Merci de l'aide que vous pourrez m'apporter!

    Mon site: citation-sur-la-vie.fr
     
  94. PH-Jay

    PH-Jay Member

    J'ai corrigé cela pour vous.
     
    LaurentD aime votre message.
  95. LaurentD

    LaurentD New Member

    Merci pour votre efficacité!
     
  96. vilto

    vilto New Member

    Bonjour,

    Dans mon cpanel le SSL est actif cependant mes sites sont toujours en HTTP. Comment afficher le Https ?

    Merci
     
  97. David77

    David77 Member

    Bonjour,
    Avez vous mis en place la redirection via htaccess ?
     
  98. vilto

    vilto New Member

    Bonjour,

    Justement je vous explique la situation : J'ai mes NDD chez OVH que je fais pointer sur les serveurs planethoster. Je me suis rendu compte que planethoster créait des sous domaines de ces NDD sur le principal prit avec l'hébergement, en plus des www, j'avais donc

    ndd1.com (OVH)
    ndd1.nddprincipal.com (Planethoster)
    www.ndd1.nddprincipal.com (Planethoster)

    J'ai donc ajouté ces lignes à mon .htaccess :

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^ndd1.com [NC]
    RewriteRule (.*) http://ndd1.com/$1 [QSA,R=301,L]

    Ce qui a fait se redirigé les url dupliquées. Maintenant je voudrais afficher le HTTPS, je dois donc mettre ces lignes ? :

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^ndd1.com [NC]
    RewriteCond %{HTTPS} off
    RewriteRule (.*) http://ndd1.com/$1 [QSA,R=301,L]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI}

    Par contre en faisant des tests j'ai vu que la vitesse de chargement du site était moins bonne en HTTPS, c'est normal ??

    Merci pour votre aide
     
  99. vilto

    vilto New Member

    Ok c'est la compresssion GZIP des https://fonts.googleapis.com qui ne marche pas en HTTPS, ce qui me donne 0,8secondes de plus en temps de chargement...
     
  100. PH-Jay

    PH-Jay Member

    Effectivement l'activation de https peut ralentir les sites faisant un grand nombre de requêtes au serveur par page, car les requêtes https demandent un chiffrement déchiffrement et un nombre plus élevé de handshakes. Afin de réduire cela tenter de réduire le nombre de connexion par page en combinant vos fichiers JS et vos CSS et en réduisant le nombre d'images.
     

Partager cette page