accès à certaine page de mon site refusé

ladylou

New Member
#1
bonjour,
S'il vous plait, à l'aide.
Lorsque je navigue sur mon site, j’accède à la page index ainsi qu' à la page réservation mais pour les trois autres pages (hebergement, tarif et photo) voici que des codes me sont demandés...

vous pouvez cliquez sur les captures pour les voir en grand, merci

quelqu'un peut m'aider à résoudre ce problème s'il vous plait


adresse de mon site:
 
Dernière édition par un modérateur:

pierre_kuhn

New Member
#2
Bonjour

Tu aurais pas rajouter une demande de mot de passe sur le site pour pouvoir le visiter ?
 

ladylou

New Member
#3
Ca serait trop facile....je suis blonde mais pas à ce point quand même..j'aurais pensé à le signaler.
la seule chose que j'ai modifié aujourd'hui c'est le fichier .htaccess dans lequel j'ai rajouté un bout de code pour essayer de resoudre mon problème de visiteurs russes qui sont présents sur le site au quotidien, je fais ce que je peux pour me débrouiller toute seule quand je n'ai pas de réponse mais là du coup je commence à provoquer d'autres ennuis plutot que de les resoudre
merci de ton aide pierre je suis sure que tu ne vas pas tarder me dire ce que je dois faire...comme supprimer mon bout de code pour voir si ca fonctionne après...n'est ce pas ?
 

ladylou

New Member
#5
bonjour David,

voilà ce que tu me demande

# -FrontPage-

Options None

<Limit GET POST>
order deny,allow
deny from all
allow from all
require group authors administrators
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthType Basic
AuthName pensionchatdu83.fr
AuthUserFile /home/pensionc/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/pensionc/public_html/_vti_pvt/service.grp


# Bloquage d'ip de spam

Order Allow,Deny

Allow from all

Deny from .ru


j'ai rajouté aujourd'hui la seconde partie du code concernant les ip à bloquer
 
#6
Bonjour :eek:

La demande de code d'accés vient de cette partie là de ton code :
Code:
AuthType Basic
AuthName pensionchatdu83.fr
AuthUserFile /home/pensionc/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/pensionc/public_html/_vti_pvt/service.grp
Pour t'expliquer:
AuthType Basic précise qu'il faut utiliser AuthUserFile pour l'authentification.
AuthName entraîne l'affichage dans le navigateur Internet de : « Tapez votre nom d'utilisateur et votre mot de passe. Domaine: "Accès protégé" »
AuthUserFile définit le chemin d'accès absolu vers le fichier de mot de passe.
AuthGroupFile définit le chemin d'accès absolu vers le fichier de groupe.
Source : http://www.commentcamarche.net/contents/apache/apacht.php3 (il y en a surement d'autres mais c'est assez bien expliqué)

J'ai vu aussi ton message sur le blocage d'ip.
Personnellement je fais comme le dis Saber, je passe par le cPanel pour les bloquer mais les robots reviennent à partir d'autres IP... C'est dur de s'en débarrasser :(
 
Dernière édition:

ladylou

New Member
#7
Bonjour :eek:

La demande de code d'accés vient de cette partie là de ton code :
Code:
AuthType Basic
AuthName pensionchatdu83.fr
AuthUserFile /home/pensionc/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/pensionc/public_html/_vti_pvt/service.grp
J'ai vu aussi ton message sur le blocage d'ip.
Personnellement je fais comme le dis Saber, je passe par le cPanel pour les bloquer mais les robots reviennent à partir d'autres IP... C'est dur de s'en débarrasser :(
david, quand je dis que ce sont exactement les mêmes IP que j'ai bloqué qui reviennent, ce sont exactement les mêmes, il ne s'agit même pas d'IP dynamiques (certaines oui d'accord là je comprends, mais d'autres sont identique je bloque par exemple l'IP
193.106.136.63 eh bien le lendemain la meme ip 193.106.136.63 revient avec une adressee HTTP identique ou differente mais l'IP est là même !

Que dois je faire pour mon petit problème d'accès ?
 
#8
C'est étrange personnellement je n'ai jamais revu une IP bloquée revenir :-/

Pour ton problème d’accès enléve la partie de code citée et ça devrait aller;)
 

ladylou

New Member
#9
merci je vais aller faire ça immédiatement et je reviens te dire

voilà un extrait de ce que j'avance
 
Dernière édition par un modérateur:
#10
par contre si tu bloque une IP via le cPanel, tu devrais avoir ça dans ton fichier .htaccess:
Code:
deny from 193.106.136.63
Et une ligne de ce type pour chaque IP bloquée...
 

ladylou

New Member
#11
Yes Ca fonctionne ! rapide et efficace ! un grand merci David...ma question maintenant et tu t'en doutes est de savoir (sachant que je n'ai pas touché à cette partie du code) pourquoi a -t-elle posé problème aujourd'hui ? il y aurait -il une incompatiblité possible avec la seconde partie du code que j'ai rajouté ?
 
#12
"Croisage" de message ;)

de où vient ta capture?
voilà ce que je vois dans mon cPanel, dans la partie "Gestionnaire des refus d'IP"
IP bloquées.JPG
 
#13
Yes Ca fonctionne ! rapide et efficace ! un grand merci David...ma question maintenant et tu t'en doutes est de savoir (sachant que je n'ai pas touché à cette partie du code) pourquoi a -t-elle posé problème aujourd'hui ? il y aurait -il une incompatiblité possible avec la seconde partie du code que j'ai rajouté ?
Tu n'as pas fait un copier/coller de ce code dans ce fichier?
As-tu utilisé la fonction "Protéger les répertoires par mot de passe" du cPanel?
 

ladylou

New Member
#14
eh bien à vrai dire je ne peux pas te dire ce qu'il y avait dans le .htaccess car c'est vraiment la première fois aujourd'hui que j'allais mettre mon nez dans ce fichier pour rajouter le bout de code et donc effectivement je n'ai pas eu à effacer ces lignes dont tu parles dans ce fichier (les IP bloqués apparaissaient pourtant bien dans le cpanel)...par contre maintenant que j'ai rajoutémon bout de code, dans le cpanel il ya bien un blocage pour tout .ru et les adresses ip que j'avais bloqué se sont donc automatiquement effacés...on va voir ce que ça dit..je vous tiens au courant dans les jours à venir
 
#15
apparemment tu as du faire ton site avec frontpage, aurais-tu pu effectuer des réglages avec ce logiciel qui auraient pu générer le .htaccess? (ça fais 15 ans que je n'ai plus utilisé ce logiciel ^^)

mais oui dis nous si ces visiteurs reviennent ;)
 
Dernière édition:

ladylou

New Member
#16
ouh là attend, là ca devient le bins dans le croisage des posts je te suis plus..

lorsque tu m'as demandé de te faire un copier coller du fichier htaccess j'ai copier la partie qui s'y trouvait déjà (sans que je ne la change ou la transforme,) elle y était déjà quand j'ai rajouté mon petit bout de code pour bloquer les ip spams

pour le tableau du cpanel dont j'ai fait la capture d'écran plus haut c'était le tableau relatifs aux visites evidement je pouvais plus te faire la capture du gestionnaire des ip bloqués puisqu'elles se sont effacées toutes seule quand j'ai rajouté mon bout de code..tu me suis ?
 

ladylou

New Member
#17
j'ai fait mon site avec mon pauvre bloc note :eek:

y a t-il encore un truc que je devrais verifier pour eviter de mauvaises surprises ? j'ai bien fait d'effacer la partie concernée??
 
#18
lol j'avoue

lorsque tu m'as demandé de te faire un copier coller du fichier htaccess j'ai copier la partie qui s'y trouvait déjà (sans que je ne la change ou la transforme,) elle y était déjà quand j'ai rajouté mon petit bout de code pour bloquer les ip spams
Donc ce code (se trouvant au dessus de "# Bloquage d'ip de spam") a du être généré par le logiciel que tu as utilisé pour créer ton site.
As-tu, lors de sa création, voulu bloquer l'accés d'une partie de ton site à certains visiteurs?

pour le tableau du cpanel dont j'ai fait la capture d'écran plus haut c'était le tableau relatifs aux visites evidement je pouvais plus te faire la capture du gestionnaire des ip bloqués puisqu'elles se sont effacées toutes seule quand j'ai rajouté mon bout de code..tu me suis ?
Hum...
Donc le copier/coller ne correspond pas à l'intégralité du contenu de ton fichier .htaccess?
Etrange que les IP se sont "effacées" toutes seules :confused:
Essai de bloquer à nouveau des IP via le cPanel et regarde si le bout de code cité un poil plus haut apparait dans ton .htaccess ;)
 

ladylou

New Member
#19
le copier coller que j'ai fait du htaccess était l'intégral de ce qu'il y avait dans le fichier, rien de plus, rien de moins..tu veux que je te refasse le copier coller maintenant que j'ai effacé la partie concernée ?

pour les IP, je me réexplique tu vas comprendre...maintenant que j'ai mis le bout de code pour bloquer tous les IP en provenance de .ru ; toutes les adresses IP concernant le .ru seront bloquées....comme, les IP que j'avais bloqué ligne par ligne contenaient toutes des .ru , il est normal qu'elles se soient effacées (enfin je pense) quand j'ai rajouté mon bout de code...puisqu'elles sont toutes concernées par l'interdiction...tu me suis mieux ?

pour répondre à ta première question, non je n'ai jamais voulu bloquer aucun visiteurs avant l'invasion des russes..de toute façon il me manquait les compétence pour le faire, j'ai déjà du mal à m'en sortir...
 
Dernière édition:
#20
le copier coller que j'ai fait du htaccess était l'intégral de ce qu'il y avait dans le fichier, rien de plus, rien de moins..tu veux que je te refasse le copier coller maintenant que j'ai effacé la partie concernée ?
Non ça va aller ;)

pour les IP, je me réexplique tu vas comprendre...maintenant que j'ai mis le bout de code pour bloquer tous les IP en provenance de .ru ; toutes les adresses IP concernant le .ru seront bloquées....comme, les IP que j'avais bloqué ligne par ligne contenaient toutes des .ru , il est normal qu'elles se soient effacées (enfin je pense) quand j'ai rajouté mon bout de code...puisqu'elles sont toutes concernées par l'interdiction...tu me suis mieux ?
Ok bah tu nous diras si ils reviennent ou pas ;)

pour répondre à ta première question, non je n'ai jamais voulu bloquer aucun visiteurs avant l'invasion des russes..
Bizarre que ce bout de code ait été dans ton .htaccess alors... mais bon c'est résolu ;)
 

ladylou

New Member
#21
;)oui merci david effectivement le principal est que ce soit resolu on va pas faire une rallonge.. c'est certain quand tout est plus clair cela permet de mieux comprendre les tenants et les aboutissants mais bon on aura peut être une réponse concernant le contenu du htaccess ulterieurement...
par contre je ne crois pas avoir protegé les repertoire par mot de passe....si tu as encore 5 minutes ou plus tard dans la soirée , j'aimerai bien connaitre le chemin à suivre sinon je sens que je vais pas dormir...merci encore de ta patience
 

ladylou

New Member
#22
j'ai trouvé le chemin et voilà le message

Avertissement !:
En raison extensions pour FrontPage installées et activées, la protection de répertoire par mot de passe ne marche pas. Si on veut utiliser cette option au lieu de FrontPage, il faut désactiver les extensions pour FrontPage.

On peut créer des répertoires protégés par mot de passe directement en FrontPage, juste comme on le peut par cette option-ci. On peut aussi désactiver les extensions pour FrontPage et quand même utiliser FrontPage pour publier le design du site par Webdav ou FTP.


encore une histoire de frontpage...que dois je faire ? mon bloc note = frontpage ??
 

ladylou

New Member
#24
merci pour ta réponse pierre, je viens de tous les effacer à l'exception d'un que j'ai ouvert avant...il est indiqué "ne pas le supprimer" alors je te demande confirmation, c'est le _vti_inf.html, je le supprime aussi ? concrètement, quelles seraient les conséquences si j'effaçais ces dossiers alors qu'il ne le faut pas ?
 

pierre_kuhn

New Member
#25
Garde le lui, c'est dossier sont la pour frontpage seulement.

PS j'ai plus ton tel donc je peux pas chercher avec toi au tel.
 

ladylou

New Member
#26
ok alors j'ai gardé celui qui se nomme _vti_inf.html et j'ai toujours le même message d'erreur dans la protection des repertoires..tu crois que par téléphone , ca sera plus simple ? pas sure parce que je vais te monopoliser une bonne partie de la soirée et cela va vite t'ennerver de voir que je ne saisis pas tout immédiatement..;alors que par post je prends le temps de la reflexion et je ne suis pas stresser si je ne trouve pas immédiatement et en plus cela peut servir pour quelqu'un d'autre...mais s'il n'y a pas d'autre moyen pour resoudre mes problèmes je ne suis pas contre.
 

ladylou

New Member
#28
A jouer ? je sais pas si c'est vraiment le terme :) mais sinon oui seule administratrice, mon mari n'y comprends absolument rien , je ne peux compter que sur moi et votre aide. Je vais passer un coup de balai dans le navigateur et je reviens te dire.
 

ladylou

New Member
#29
voilà tout a été nettoyé et retour sur la protection des repertoires avec toujours même message.

si j'efface le_vti_inf.html et que ça pose un souci est ce que je pourrai le recrée ?
 
#30
Je ne connais pas trop c'est quoi ton problème je n'ai pas eu le temps de lire tous les messages mais avant les modification tout fonctionner super bien ?

C'est étrange personnellement je n'ai jamais revu une IP bloquée revenir :-/

Pour ton problème d’accès enléve la partie de code citée et ça devrait aller;)
Ce sont des IPs zombies MOUHAHAHAHAHA xD

Bon je sors =>
 
Dernière édition:

ladylou

New Member
#31
:D bien vu gaara !! mais y a que moi pour les croiser les zombies...enfin un grand merci à pierre qui a mis de la lumière à tous les étages, grâce à lui, et david, et toi aussi gaara j'y vois plus clair !!
thank you !

ps: je vous dirai quand même si mon code fonctionne, cela peut être utile.
 
#32
On espère que cela fonctionne bien !

Dis moi quand ton site serait fini et créer aussi des pages genre des fiches perso pour les races de chats et de chiens, j'ai besoin de renseignements pour adopter un chat.
 
Haut