Accéder à la base de données PostgreSQL à distance ?

Discussion dans 'Hébergements Mutualisés' démarrée par unreal, Nov 16, 2013.

  1. unreal

    unreal New Member

    Bonjour à tous,

    Je souhaiterais savoir s'il est possible d'accéder à sa base de données postgresql à distance (chez planethoster) à partir de PDO ?

    En effet si je fais :

    PHP:
    $bdd = new \PDO('pgsql:host=IpDuSite; port=5432; dbname=Nom_Base''Nom_Utilisateur''MotDePasse');
    en remplaçant par les bons termes, j'ai un message d'erreur comme quoi la connexion et impossible ou que le serveur n'écoute pas.

    Qu'est ce que je dois changer ? Je suis sur un serveur mutualisé.

    Le but serait que je puisse construire mon site en local en utilisant la base de données à distance.

    Merci d'avance !
     
  2. David77

    David77 Member

    Bonjour,

    Je ne sais pas si ça a à voir avec ça mais il y a l'option "MySQL distant" dans le cPanel, où tu dois mettre l'IP distante qui va se connecter à la base de données afin de l'autoriser....
     
  3. unreal

    unreal New Member

    Merci pour ta réponse.
    Oui j'avais vu cette option. J'avais bien rentré mon adresse IP mais cela ne change rien. J'ai toujours le message :

    Code:
    Erreur : SQLSTATE[08006] [7] could not connect to server: Connection refused Is the server running on host "85.236.***.***" and accepting TCP/IP connections on port 5432?
    
     
  4. pierre_kuhn

    pierre_kuhn New Member

    Bonjour

    IL me semble que le port est 3306 mais bon à essayez.
     
  5. unreal

    unreal New Member

    Ok, merci beaucoup. J'avance. Mais j'ai maintenant une nouvelle erreur :

    Code:
    Erreur : SQLSTATE[08006] [7] expected authentication request from server, but received �
    
    ou bien

    Code:
    Erreur : SQLSTATE[08006] [7] server closed the connection unexpectedly This probably means the server terminated abnormally before or while processing the request.
    


    J'ai pourtant mis le nom de l'utilisateur qui a le droit d'accéder à la base ainsi que son mot de passe mais cela ne change rien.

    J'ai essayé mes login/motDePass pour mon hébergement mais idem.

    De nouvelles idées ?
     
    Dernière édition: Nov 17, 2013
  6. unreal

    unreal New Member

    Je corrige : le port 3306 est pour mysql et non postgresql. Donc en fait, cela ne marche pas.
     
  7. unreal

    unreal New Member

    Bonjour,

    J'ai finalement résolu le problème en utilisant mysql (et en créant une connexion à distance avec mysql distant). Mais cela ne fonctionne pas avec la base de données postgresql.

    Je crois que l'accès à distance avec postgresql ne fonctionne pas ou que cela n'est peut-être pas permis par les serveurs de planethoster.

    Dommage, j'aurais aimé utilisé postgresql pour cela.
     

Partager cette page